it-swarm.com.de

Fehler beim Ausführen von Android Project - Nicht unterstützte Hauptversion

Während der Code ausgeführt wird, wird eine Warnung angezeigt

Beim Build sind Fehler aufgetreten Fehler beim Ausführen des Builders 'Android Package Builder' über das Projekt 'Test'.com/Android/dx/command/dexer/Main: Nicht unterstützte Major-Minor-Version 52.0

 This is the error shown

Eclipse lief ordnungsgemäß, aber nach der Aktualisierung von Eclipse wird der Fehler angezeigt. Vorher war es gut, d.

helfe mir auch mit einem updatefähigen adt-Bundle.

16
Vishnu M A

Das Problem wurde behoben. Vorher habe ich mit Java 1.7 kompiliert und in jdk 1.8 ausgeführt. Das war der Grund für mein Problem. Jetzt lade ich Java 1.8 herunter, jetzt wird es ausgeführt

  • J2SE 8 = 52,
  • J2SE 7 = 51,
  • J2SE 6,0 = 50,
  • J2SE 5.0 = 49 
  • JDK 1,4 = 48
  • JDK 1,3 = 47
  • JDK 1,2 = 46
  • JDK 1,1 = 45

 enter image description here

4
Vishnu M A

Ich habe das gleiche Problem, aber nicht die gleiche Lösung hat es gelöst:

Um dies zu beheben, muss ich in meine project.properties-Datei gehen:

 enter image description here

Und fügen Sie in dieser Datei diese Zeile hinzu:

sdk.buildtools=23.0.3
50
Kevin ABRIOUX

ihr Code wurde möglicherweise mit der Java Higher-Version (d. h. 8) kompiliert, während Sie versuchen, ihn mit der Java Lower-Version (d. h. 7) auszuführen. Beachten Sie, dass Eclipse über einen eigenen Compiler verfügt und nicht den aus dem JDK verwendet. Höchstwahrscheinlich ist es für die Verwendung der Java Higher-Version (d. H. 8) konfiguriert. Überprüfen Sie die Eclipse-Compiler-Einstellungen.

4
Pratik Tank

Der einzige Grund für Nicht unterstützte major.minor-Version 52.0 in Eclipse ist der API-Level 24

Bitte führen Sie folgende Schritte aus, um das Problem in Eclipse zu lösen:

  1. GO to Window Menü
    2.Öffnen Android SDK Manager
    3. Überprüfen Sie, ob der API-Level 24 auf einer beliebigen Plattform installiert ist
    4.IfYESBitte deinstallieren Sie diese API Level 24-Pakete.
    5. Reinigen Sie das Projekt und führen Sie es erneut aus.

Und es funktioniert gut.

3
Kishor Patil

Das Hinzufügen der folgenden Zeile in project.properties und das Setzen von Java auf 1.7 löste das Problem für mich.

sdk.buildtools = 23.0.3

0
Amar