it-swarm.com.de

Eclipse auf einem Mac ausführen - JVM Version 1.7 oder höher ist erforderlich

Ich habe Eclipse (speziell für die C/C++ - Programmierung) für Mac mit OSX Mavericks heruntergeladen. Wenn ich versuche, Eclipse zu starten, wird mir die folgende Meldung angezeigt: "Version 1.6.0_65 der JVM ist für dieses Produkt nicht geeignet. Version 1.7 oder höher ist erforderlich" und kann nicht geöffnet werden. Ich habe Java Version 7 installiert, aber es hat sich nichts geändert. Ich weiß nicht, wie ich die JVM sonst aktualisieren sollte (ich weiß nicht viel über Java im Allgemeinen). 

Ich habe die 64-Bit-Version für mein MacBook Air heruntergeladen, wenn das wichtig ist.

10
Tchaikovsky

Installieren Sie einfach das JDK 7 oder JDK 8 und nicht nur das neueste JRE. 

19
Nadeem

Führen Sie whereis Java in einem Terminal aus. Normalerweise wird etwas wie /usr/bin/Java angezeigt.

Führen Sie nun Java -version aus. Es zeigt Ihnen "Java Version 1.6.0_65" oder etwas, das sich nähert. Dies ist darauf zurückzuführen, dass Java 7 Java 6 nicht ersetzt. Java 7 wird als Internet Plug-In installiert und befindet sich in /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/Java.

Was Sie tun müssen, ist, /usr/bin/Java mit /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/Java zu verknüpfen.

Starten Sie Eclipse neu, oder starten Sie Ihren Computer neu (ich weiß nicht, wie Eclipse dies bewerkstelligt). :)

1
Richard-Degenne

fügen Sie dieses Skript oben in 'Eclipse.ini' ein'/Library/Java/JavaVirtualMachines/jdk1.8.0_77.jdk/contents/Home/bin'

0
LKM

Beim Versuch, Eclipse zu installieren, installierte ich die Java-Version 1.6.0_65 wie gewünscht, konnte jedoch die Installation der Eclipse-Installation nicht beenden. Der Fehler bestand darin, dass ich JVM 1.7 oder höher benötigte. Ich habe versucht, jdk-8u101-macosx-x64.dmg zu installieren, und das hat nicht funktioniert. Also, ich habe JDK 7 wie empfohlen ausprobiert, tut mir leid, nichts Gutes.

Damit das Eclipse-Installationsprogramm diesen Java-Fehler nicht ausführen kann, musste ich die Info.plist im Eclipse-Installationsprogramm bearbeiten. Klicken Sie mit der rechten Maustaste auf das Eclipse-Installationsprogramm, zeigen Sie den Paketinhalt an, und öffnen Sie info.plist in textEdit.app

(Hinweis: Nach mehreren Versuchen, diese Plist zu bearbeiten und den an anderen Stellen genannten Methoden zu folgen, hat nichts funktioniert, habe ich festgestellt, dass Sie den Symlink oder Java-Alias ​​verwenden müssen, da Java nun schon seit Tagen als Internet-Plugin anders installiert ist.)

Wo möchten Sie eine Bearbeitung vornehmen (Sie sollten wahrscheinlich das Original sichern oder Sie können es erneut herunterladen), löschen Sie unter <key>Eclipse</key>, dann <array> das Vorhandene und fügen Sie <string>-vm</string> und diese Zeichenfolge darunter hinzu. <string>/usr/bin/Java</string> 

So sieht meins aus.

<key>Eclipse</key>
<array>
<string>-vm</string>
<string>/usr/bin/Java</string>
<string>-keyring</string>
<string>~/.Eclipse_keyring</string>
<string>-showlocation</string>
</array>

Speichern Sie dann das Eclipse-Installationsprogramm und führen Sie es aus. das hat für mich funktioniert.

0
CGnewbie

Ich ging zu Oracle-Downloads und der scrollte einen der verschiedenen Mac OSX-Links und lud jdk-8u73-nb-8_1-macosx-x64.dmg von Oracle herunter und das Problem wurde behoben. Ich weiß nicht, warum das Aktualisieren von Java nicht ausreicht.

0
user3552900

Nur den unten stehenden Befehl von dort aus auszuführen, funktionierte für mich.

brühfass installieren Java

Es hat mein IDK mit 1.8 aktualisiert, und Eclipse wird danach erfolgreich geöffnet.

0
PINTU KUMAR