it-swarm.com.de

Aktualisieren Sie das Android Studio Gradle-Plugin auf die letzte Version

Ich bin neu in der Android-Entwicklung und habe versucht, das Facebook SDK in meinem Android Studio-Projekt zu installieren.

Dann habe ich einen Fehler in build.gradle:

Error:(111, 0) Cannot call getBootClasspath() before setTargetInfo() is called.

Also habe ich nach einer Lösung gesucht und diese auf dem Stack gefunden: 

Dies ist ein bekanntes Problem, das durch Aktualisieren von Gradle behoben wird:

dependencies {
classpath 'com.Android.tools.build:gradle:1.1.2'
}

Also habe ich es versucht, aber dann bekam ich den Fehler: 

Error:Could not find com.Android.tools.build:gradle:1.1.2.
Searched in the following locations:
file:/home/roman/Documents/softs/Android-studio/gradle/m2repository/com/Android/tools/build/gradle/1.1.2/gradle-1.1.2.pom
file:/home/roman/Documents/softs/Android-studio/gradle/m2repository/com/Android/tools/build/gradle/1.1.2/gradle-1.1.2.jar
Required by:
Yoki:facebook:unspecified

Also bin ich in das angegebene Verzeichnis umgezogen und dann gibt es nur noch folgendes:

$>  ls  
1.0.0  1.1.0
$>  pwd
/home/roman/Documents/softs/Android-studio/gradle/m2repository/com/Android/tools/build/gradle

Wie kann ich das Gradle-Plugin aktualisieren?

10
Jidey

Ändern Sie Ihren buildscript-Block. In diesem Block müssen Sie also die Repositorys angeben.

buildscript {
    repositories {
        mavenCentral()
    }

    dependencies {
        classpath 'com.Android.tools.build:gradle:1.1.2'
    }
}

Sie können auch die letzte Version verwenden:

        classpath 'com.Android.tools.build:gradle:1.1.3'
5

In Android-Gradle-Dateien gibt es drei Arten von Abhängigkeiten.

1. Modulabhängigkeit: anderes lokales Projekt.

2. Lokale Abhängigkeit: im extras-Ordner für den Sdk-Pfad.

3. Remote-Abhängigkeit: JCenter, MavenCenter oder Maven-Pfad eines Drittanbieters.

'com.Android.tools.build:gradle' ist eine lokale Abhängigkeit, daher müssen Sie Ihre SDK überprüfen und das Update durchführen.

P.S. Wenn Sie mit dem Versionsproblem müde sind, können Sie andle versuchen.

Es ist ein Open-Source-Projekt, um die Android-Abhängigkeitsversion automatisch zu aktualisieren.

Weitere Informationen finden Sie unter https://github.com/Jintin/andle

2
Jintin

Ein regelmäßig aktualisiertes Online-Handbuch. Erläutert die aktuellste Version und die Quelle der Veröffentlichungen. So aktualisieren Sie mithilfe einzelner Textänderungen in Verlaufsdateien.

Leitfaden zur Aktualisierung auf die neueste Version

basierend auf https://docs.gradle.org/current/release-notes

0
Jayakrishnan PM