it-swarm.com.de

pod-Problem, Linker-Befehl mit Exit-Code 1 fehlgeschlagen

wenn ich mein Projekt starte, erhalte ich folgende Fehler: enter image description here

Es scheint, dass alle Rahmen in meinen Kokosapoden ein Problem haben. Ist es mein Problem mit meinen Kokosapoden? Ich habe meine Cocoapods neu installiert und "Pod Setup" oder "Pod Install" und andere verwendet, aber es funktioniert nicht und ich habe immer noch die gleichen Fehler ... und in Xcode rotes "rd" auf der "Podfile" wie folgt, ich weiß nicht, ob es sich um Fehler handelt .enter image description here

pod 1.0.0 Ruby 2.0.0 xcode 7.3.1 Hat jemand das gleiche Problem?

15
MeR8.

Ich hatte in meinem Projekt ein ähnliches Problem. Nach stundenlangem Suchen fand ich, dass in den ALLGEMEINEN Einstellungen des Projekts im Abschnitt "Verknüpfte Frameworks und Bibliotheken" zwei Dateien für Pods vorhanden sind: "libPods.a" und "Pods_ProjectName.framework "

Das Löschen von "libPods.a" hat in meinem Fall geholfen.

 Linked Frameworks and Libraries

28
Bastek

Das hat für mich funktioniert:

pod deintegrate 
pod install 
22
al_mukthar

Tatsächlich bezieht sich das Problem auf das Abhängigkeitsmanagement für das xcode-Projekt. Sie können den Antwortlink unten verwenden, um das "Linker-Problem" in xcode zu lösen. Das hat bei mir funktioniert.

https://stackoverflow.com/a/38371271/6827175

10
Pawan Korade

Es kann verschiedene Fälle geben.

Es würde auch helfen, alle Informationen von Ihrem Druckbildschirm zu kennen :)

Haben Sie versucht, Ihre Lieferdaten zu bereinigen?

  1. Gehen Sie zu Xcode -> Einstellungen -> "Standortmenü" öffnen -> Ordner mit DeliveryData öffnen

  2. Schließen Sie Ihren XCode; (gehen Sie sogar zum Menü "Force Quit .." und schließen Sie XCode dort);

  3. Mülleimer reinigen;

  4. Und versuchen Sie es erneut.

Zweiter Fall:

  1. Öffnen Sie Ihr Ziel -> Build-Einstellungen -> Aktive Architektur erstellen Nur -> Option "Nein" setzen 
  2. Machen Sie dasselbe mit allen Ziel Ihrer Pods
7
Y.R.

Versuchen Sie, die Datei "Podfile.lock" und den Ordner "Pods" zu löschen. Dann versuchen Sie, Pods zu installieren.

3
Mahesh Verma

In meinem Fall steckte ich mein echtes Gerät aus, aber im Simulator sieht es immer noch aus. Also habe ich es mit einem Simulator geändert und es wurde behoben.

1
Atalay Asa

Zuerst müssen Sie Ihre Xcode-Version und dann die von Ihnen installierte Pod-Version überprüfen. Wenn Ihre Xcode-Version unter 9.0 ist, sollten Sie den Pod mit der alten Version nicht neu installieren. Es wird klappen.

1
Prasann

in meinem fall habe ich run simulator auf iphone x mit ios 11.4 geändert 

ich denke, wahrscheinlich ist das Problem in UI-Test und Komponententestkomponenten, ich hoffe, dass Apple sie repariert 

Ich habe Deployment target von 10.0 auf 11.0 geändert und das funktioniert!

 enter image description here

Gleiche Ausgaben hier. Ich hatte keine anderen Änderungen vorgenommen, als dem Projekt einige Symbole hinzuzufügen. Nach ein paar Stunden klickte ich auf das Pod-Projekt und änderte den Suchpfad in Ja. Das hat es für mich gelöst. Screenshot von xcode

0
Chris Zeis

Ich habe 2 Tage gebraucht, um den wahren Schuldigen zu finden. Es stellt sich heraus, dass ich versucht habe, das "Projekt" anstelle des "Arbeitsbereichs" auszuführen. Wie wird das anderen helfen!

0
nfek

Dies geschah bei meinem Projekt, weil ich Admob in meinem Unity-Projekt verwendet und dann für iOS erstellt habe. Ich habe nicht bemerkt, dass Unity-iPhone.xcworkspace zum Öffnen anstelle von Unity-iPhone.xcodeproj erstellt wird. Ich öffnete ständig Unity-iPhone.xcodeproj und es gab den Fehler. Das Öffnen des Projekts mit Unity-iPhone.xcworkspace hat das Problem für mich behoben. 

0
Maihan Nijat