it-swarm.com.de

"Entwickler-Image konnte nicht gefunden werden"

Ich habe kürzlich den Fehler erhalten: "Entwickler-Image konnte nicht gefunden werden"

Ich denke, das passiert, seit ich iOS auf 9.1 auf dem iPhone aktualisiert habe .. Wie kann ich das Problem beheben und Xcode iOS 9.1-Geräte unterstützen?

80
Pulkit sharma

1) Ich habe dasselbe Problem erlebt, mein Xcode-Version war 7.0.1 und ich aktualisierte mein iPhone auf Version 9.2, dann wurde bei Verwendung von Xcode mein iPhone im Abschnitt von angezeigt nicht verfügbares Gerät. Genau wie im Bild unten: 

 enter image description here

2) Aber dann gelang es mir irgendwie, mein iPhone durch Klicken auf auszuwählen
Produkt -> Ziel -> Nicht verfügbares Gerät 

 enter image description here

3) Aber das hat mein Problem nicht gelöst und es zeigte sich:

Entwicklerabbild konnte nicht gefunden werden

 enter image description here

Solution) Dann habe ich endlich die neueste Version von Xcode Version 7.2 von hier heruntergeladen und alles hat für mich gut funktioniert.

Update: Wenn die Version des iPhone-Geräts höher ist als die Version von Xcode, kann dasselbe Problem auftreten. Daher sollten Sie Ihre Xcode-Version aktualisieren, um diesen Fehler zu beheben.

18
Aamir

Xcode 7.0.1 und iOS 9.1 sind nicht kompatibel. Sie müssen Ihre Xcode-Version über den Mac App Store aktualisieren. 

Wenn Ihre iOS-Version niedriger ist als die Xcode-Version, können Sie das Implementierungsziel für eine niedrigere iOS-Version ändern, indem Sie zu den Allgemeinen Einstellungen gehen und unter Deployment Ihr Implementierungsziel festlegen:

 enter image description here

Hinweis:

Xcode 7.1 enthält kein Beta-SDK für iOS 9.2. Upgrade auf Xcode auf 7.2 Beta durch Herunterladen von der Xcode-Website .

87
Caleb Kleveter

Ich habe mit Xcode 7.3 das gleiche Problem und meine Geräteversion ist iOS 10. 

Dieser Fehler wird angezeigt, wenn der XCode alt ist und das verwandte Gerät, das Sie verwenden, auf die neueste Version aktualisiert wird. Installieren Sie zunächst die neueste Xcode-Version.

Wir können dieses Problem lösen, indem Sie die folgenden Schritte ausführen: -

  • Öffnen Sie den Finder und wählen Sie Anwendungen
  • Klicken Sie mit der rechten Maustaste auf Xcode 8 und wählen Sie "Paketinhalt anzeigen", "Inhalt", "Entwickler", "Plattformen", "iPhoneOS.Platform", "Geräteunterstützung".
  • Kopieren Sie den 10.0-Ordner (oder höher für spätere Version).
  • Im Finder wieder Anwendungen auswählen
  • Klicken Sie mit der rechten Maustaste auf Xcode 7.3 und wählen Sie "Paketinhalt anzeigen", "Inhalt", "Entwickler", "Plattformen", "iPhoneOS.Platform", "Geräteunterstützung".
  • Fügen Sie den 10.0-Ordner ein

Wenn alles richtig funktioniert hat, hat Ihr XCode ein neues Entwicklerdatenträger-Image. Schließen Sie jetzt den Finder und beenden Sie Ihren XCode. Öffnen Sie Ihren Xcode und der Fehler ist weg. Jetzt können Sie Ihr aktuelles Gerät an alte Xcode-Versionen anschließen.

Vielen Dank 

19
Mandeep Singh

Wenn die XCode-Version niedriger ist als das Image des iOS-Geräts, können Sie das Disketten-Image entweder aus einem anderen bereits aktualisierten XCode (oder möglicherweise aus dem Internet) kopieren oder Ihren XCode aktualisieren.

Das Bild ist ein Ordner mit einer Größe von mehr als 10 MB. Platzieren Sie ihn unter diesem Pfad "/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSup (port /".

Um das Xcode.app-Paket einzugeben, halten Sie die Strg-Taste gedrückt und klicken Sie auf Xcode.app. Dort finden Sie zusätzliche Optionen wie Paketinhalt anzeigen oder ein ähnliches Word. Wählen Sie diese Option aus, und Sie geben Xcode.app wie einen normalen Ordner ein. 

Ich hoffe es ist hilfreich und viel Glück!

15
Solomon

Führen Sie die folgenden Schritte aus, um das Projekt auf den neuesten Geräten aus den älteren Xcode-Versionen auszuführen:

Gehen Sie zum Finder -> Anwendungen -> Rechtsklick auf die neueste Xcode-Version -> Wählen Sie Paketinhalt anzeigen -> Entwickler -> Plattformen -> iPhoneOS.platform -> DeviceSupport -> Kopieren Sie den neuesten Versionsordner und fügen Sie ihn an derselben Stelle ein Xcode dh im Ordner DeviceSupport Ihres alten Xcodes.

Dann Xcode neu starten.  enter image description here

3
Swati Gupta

Einfach Xcode aktualisieren. Mein Problem gelöst

3
Usman Nisar

Diese Lösung funktioniert nur, wenn Sie in Xcode 7 das Verzeichnis "10.0" erstellen und in Ihrem Satz ein Fehler vorliegt:

ln -s /Applications/Xcode_8.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/10.0 \(14A345\) /Applications/Xcode_7.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/10.0
0
sgr

Wenn Sie mit Xcode 7 auf Ihrem iOS10-Gerät entwickeln möchten:
(Hinweis: Sie können diesen Befehl an andere Xcode- und iOS-Versionen anpassen.)

  1. Benennen Sie Ihre Xcode.app in Xcode7.app um und laden Sie Xcode 8 aus dem App Store herunter.
  2. Führen Sie einmal Xcode 8 aus, um es zu installieren.
  3. Öffnen Sie das Terminal und erstellen Sie mit dem folgenden Befehl einen symbolischen Link vom Ordner Xcode 8 Developer Disk Image 10.0 zum Ordner Xcode 8 Developer Disk Image: 

    ln -s /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/10.0\ \(14A345\)/ /Applications/Xcode7.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/10.0
    

Quelle

0
Bogy

Die ältere XCode-Version enthält kein Entwickler-Disk-Image für die neuere iOS-Version . Wenn Sie XCode nicht aktualisieren möchten, können Sie Ready-Entwickler-Disk-Images nach neuesten Versionen in dieser Antwort suchen: https://stackoverflow.com/a/39865199/286361

0
Vladimir