it-swarm.com.de

die Übermittlung der iOS-App führt zu "ungültiger Toolchain", obwohl Xcode auf dem neuesten Stand ist

Ich habe meine App mit Xcode 6.4 unter OS X 10.11 an den App Store übermittelt. Die App wurde zum Testen vorab genehmigt. Ich habe dann 5 Builds durchlaufen, die alle erfolgreich hochgeladen und auf mehreren Testgeräten installiert wurden. Jetzt, wo ich versuche, die endgültige Genehmigung einzureichen, bekomme ich:

"Invalid Toolchain. New apps and app updates must be built with the public (GM) versions of Xcode 6 or later, and iOS 8 SDK or later. Don't submit apps built with beta software."

Wie kann man davon ausgehen, dass ich Xcode 6.4 verwende, dass die App für iOS 8 oder höher ausgeführt wird und alle vorherigen Builds, einschließlich der aktuellen, nur gut in das Testprogramm aufgenommen und installiert wurden?

Weiß jemand, wie ich diese Situation korrigieren könnte, um meine App in den letzten Schritt zu bringen?

11
Kirill

OS X 10.11 El Capitan ist eine Beta-Software, mit der Sie keine iOS-App erstellen und beim Store einreichen können.

Es gibt einen schmutzigen Weg, um es zu verwalten, aber ich persönlich würde es nicht tun https://stackoverflow.com/a/32233429/3979236

15
Nicolas Braun

Wenn Sie eine Betaversion eines nicht GM Xcode installiert haben, ist Ihre Toolchain möglicherweise verwirrt.

Gehen Sie in den Xcode-Einstellungen zu Accounts, wählen Sie den Kontonamen, unter dem Sie veröffentlichen möchten, und zeigen Sie Details an.

In Signing Identities > Action entweder Create die fehlende oder Reset die beleidigende.

0
SwiftArchitect

Für jeden, der diese Fehlermeldung bei der Verwendung von xcode 7 beta erhält.

Ich ging in den Appstore und lud xcode 7.0.1 herunter, archivierte und veröffentlichte es und es funktionierte beim ersten Versuch gut.

0
Kristian