it-swarm.com.de

Das Xcode 10-App-Symbol wird nicht angezeigt

Kürzlich auf Xcode 10 Beta aktualisiert, und bei meiner App, die zuvor ein korrektes Symbol angezeigt hat, als sie erstellt und von Xcode 9.4 auf das Gerät ausgeführt wurde, wird bei der Ausführung in Xcode 10 jetzt das standardmäßig leere Symbol angezeigt.

 enter image description here

Beim Öffnen von AppIcon Asset wird das Symbol in allen Platzhaltern ohne Warnsymbole richtig angezeigt. Beim Tippen auf neues "Show Slicing" sehe ich nichts.

Gibt es irgendwelche Hinweise, wie das App-Symbol behoben werden kann?

21
Vlad

Am 19.06.18 veröffentlichte Apple xCode 10. Beta 2. Durch das Upgrade wurde das Problem behoben, bei dem Symbole nicht angezeigt wurden. Also, ein Fehler in xCode 10.0, denke ich.

6
Peter Wiley

Das gleiche Problem tritt nach der Aktualisierung auf Xcode 10 Beta auf.

Ich könnte das Problem beheben, indem ich das aktive Entwicklerverzeichnis auf Xcode 10 umstelle:

Sudo xcode-select --switch /Applications/Xcode-beta.app/Contents/Developer

Oder wählen Sie Xcode 10.0 in Xcode->Preferences->Locations->Command Line Tools.

Hoffe das hilft.

 enter image description here

4
edison

In meinem Fall waren diese beiden Optionen falsch eingestellt Project navigator

2

Ich habe dieses Problem nach dem Ändern von Asset-Katalogen erhalten. Ich glaube, was behoben wurde, war die Auswahl des AppIcon-Assets und das Auswählen und Abwählen der Zielmitgliedschaft für das Hauptziel der App. Dies war auf Xcode 10 richtig.

0
yairsz

Ich habe auf dem iPad getestet. In meinem Fall bestand das Problem darin, dass das Standard-AppIcon keine iPad-Steckplätze enthielt.

Ich weiß nicht, ob dies etwas mit der Initialisierung meiner App zu tun hat (ich benutze Reactate native), aber ich habe seit Ewigkeiten Probleme mit dem Beheben von Fehlern gehabt und nicht einmal darüber nachgedacht, ob sie da waren. Wie dumm von mir...

Um das Problem zu beheben, entfernte ich die vorhandenen Symbole, klickte auf die Schaltfläche + und wählte ['App-Symbole und Elemente starten' -> 'Neue iOS-App-Symbole'] aus. Dann habe ich wie erwartet nur bevölkert.

 add new buttons

0
James Trickey

In meinem Fall verwendete der Xcode in der Quelle der App-Symbole "Asset-Katalog verwenden". Um zu sehen, dass Sie auf Project-> General-> App Icons Source gehen können. 

Um das Problem zu beheben, habe ich "Migrate" ausgewählt und einen neuen Assets-Katalog erstellt. Als ich das tat, erhielt der älteste Bestandskatalog eine Warnung im App-Symbol. Also habe ich die Icons wieder in diesen ältesten Katalog hochgeladen und den vorläufigen Katalog gelöscht. 

Die App-Icons-Quelle kehrte zurück, um "AppIcon" anzuzeigen, und es funktionierte.

0
Matheus Gomes

Ich habe den ganzen Tag damit gekämpft, es würde weder im Simulator noch auf einem echten Gerät auftauchen.

Schließlich habe ich es geschafft, indem ich sicherstellte, dass als Zielmitgliedschaft für das AppIcon der Name der App festgelegt wurde und dass der Ort "Relativ zum Projekt" war.

 Xcode screenshot

0
developius

Stellen Sie sicher, dass für Ihre "App-Symbol-Quelle" Ihr AppIcon unter "App-Symbole und Startbilder" ausgewählt ist. Manchmal kann Ihr AppIcon so etwas wie "AppIcon-1" im Ordner Assets.xcassets heißen.

0
Brendan Ballon