it-swarm.com.de

ARKit Demo Crashing auf dem iPhone 6/iPhone 6 Plus

Ich arbeite mit ARKit Feature , mit der letzten großen iOS-Version, aber ich bekomme einen Absturz mit dem Fehler failed assertion

MTLRenderPassDescriptor: Die Speicheraktion MTLStoreActionMultisampleResolve für die Tiefenanbringung wird vom Gerät nicht unterstützt

Ich habe bereits iOS11 Beta auf meinem iPhone-Gerät installiert.

7
Svitlana

Wie alle obigen Antworten ist dies ein hardware constraint zu A9-Chips. Auf jeden Fall ist es eine gute Praxis, das Hinzufügen von ARKit zu UIRequiredDeviceCapabilities in Info.plist hinzuzufügen. Dadurch erhalten Sie ein besseres Feedback, wenn Sie Apps ausführen, deren primäre Funktion ARKit ist. 

2
Boris Ch.F

Um ARKit ausführen zu können, sollte Ihr Gerät dies unterstützen können. Es hilft nicht nur das neueste iOS zu verwenden. Wie Apple in der Keynote WWDC 2017 erwähnt, unterstützen sie A9-Chips und Above, was bedeutet, dass iPhone 6s und Above ARKit ausführen und testen können.

1
Khalid Afridi