it-swarm.com.de

Warum kann Ubuntu Make Intellij IDEA nicht auf 16.04 installieren?

Unter Ubuntu 16.04 gibt das Ausführen von umake ide idea Folgendes zurück:

usage: umake ide [-h] {lighttable,visual-studio-code} ...
umake ide: error: argument framework: invalid choice: 'idea' (choose from 'lighttable', 'visual-studio-code')

Ubuntu Make bietet mir nur zwei IDEs zur Installation an: Lighttable und Visual-Studio-Code. Laut der Manpage und https://wiki.ubuntu.com/ubuntu-make sollte es jedoch viel mehr Optionen geben ("Idee" unter ihnen). Was ist los mit dir?

5
ARX

Die Version von ubuntu-make in den 16.04-Paketen unterstützt IntelliJ nicht. Laut TechGeeks benötigen Sie mindestens die Version 16.03 (die Version in Ubuntu 16.04 ist 16.02.1). Führen Sie dazu Folgendes aus (falls es sich um eine Neuinstallation handelt):

Sudo add-apt-repository ppa:ubuntu-desktop/ubuntu-make
Sudo apt update
Sudo apt install ubuntu-make

Wenn Sie es noch installiert haben, können Sie einfach Folgendes tun:

Sudo add-apt-repository ppa:ubuntu-desktop/ubuntu-make
Sudo apt update
Sudo apt dist-upgrade

Dies brachte meine Ubuntu-make-Version auf 16.09 und ich konnte IntelliJ IDEA mit dem Befehl installieren, den Sie in Ihrem Beitrag verwendet haben.

8
desilvai