it-swarm.com.de

Notepad ++ Installationsfehler: Installation des Plugins fehlgeschlagen

Ich habe die neueste Version von Notepad ++ auf meinem Win 8.1 Professional installiert. Die Version heißt "Notepad ++ Je suis Charlie Edition, Build Time Jan 10 2015 - 17:20:21". Der mit dieser Version von Notepad ++ gelieferte Plugin Manager ist 1.0.8. Jetzt möchte ich das "Compare" -Plugin hinzufügen:

  • Ich starte den Plugin Manager.
  • Ich warte bis sich die Liste der verfügbaren Plugins aufgebaut hat.
  • Ich überprüfe "Vergleichen" und klicke auf "Installieren".
  • Msgstr "Ein Update für den Plugin Manager ist verfügbar. Es wird dringend empfohlen ..." -> "Ja".
  • "Installationsfehler: Installation von Plugin Manager fehlgeschlagen."
  • "OK" und "Installieren" erneut.
  • Msgstr "Für Plugin Manager ist ein Update verfügbar. Es wird dringend empfohlen ..." -> "Nein".
  • "Installationsfehler: Installation von Compare fehlgeschlagen."

Was genau mache ich falsch? Wie kann ich dieses Problem beheben?

23
Alexander

Fehler: Installation des Plugins fehlgeschlagen

Die neueste Version des Plugin Managers war 1.4.9 zum Zeitpunkt der Erstellung dieser Antwort (siehe Notepad ++ Plugin Manager )

Sie finden die neueste Version immer unter https://github.com/bruderstein/nppPluginManager/releases/ .

Versuchen Sie eine manuelle Installation des Plugin Managers:

  1. Schließen notepad++

  2. Laden Sie den neuesten Plugin-Manager PluginManager_1.4.9_UNI.Zip von https://github.com/bruderstein/nppPluginManager/releases/download/v1.4.9/PluginManager_v1.4.9_UNI.Zip

  3. Entpacke die heruntergeladene Datei

  4. Kopieren Sie plugins\PluginManager.dll in Ihr notepad++\plugins-Verzeichnis

  5. notepad++ neu starten

20
DavidPostill

Ich hatte dieses Problem und die Lösung war einfach:

  1. Gehe über Plugins -> Plugin Manager -> Show Plugin Manager zum Plugin Manager
  2. Klicken Sie auf die Registerkarte Installed
  3. Plugin Manager prüfen
  4. Reinstall

Notepad ++ wird nach der Eingabeaufforderung automatisch neu gestartet und das Problem ist behoben.

enter image description here

Systemsteuerung -> Internetoptionen -> Erweitert Blättern Sie nach unten zu Sicherheit. Stellen Sie sicher, dass TLS 1.0, TLS 1.1 und TLS 1.2 aktiviert sind.

Viel Glück!

4
Sam

Was schließlich für mich funktionierte, war, einfach die ComparePlugin.dll-Datei von einem anderen PC zu kopieren, auf dem das Plugin installiert war. Der Dateispeicherort ist:

C:\Program Files (x86)\Notepad++\plugins\ComparePlugin.dll
1
RenniePet

Ich hatte gerade wieder das gleiche Problem (in der aktuellen Version 6.9) und habe eine Problemumgehung gefunden:

Ich habe gerade das "AutoSave" -Plugin ausgewählt. Wenn ich auf "Installieren" geklickt habe, ist dies bei der Installation des AutoSave-Plugins fehlgeschlagen, aber Compare, der Zweite, lief reibungslos ab und das Compare-Plugin kann jetzt verwendet werden.

Wenn Sie also nicht das erste Plugin in der Liste installieren möchten, ist diese Problemumgehung einen Versuch wert.

0
Alexander

Ich benutze das Betriebssystem win10 und meinen Systemtyp 64x. Wie auch immer, ich habe notepadd ++ von der notepad ++ - Website auf x64 installiert. Aber Plugin-Manager hat Probleme bei der Installation von "ProgramFiles". Ich habe um entfernt und auf 32-Bit (x86) installiert. Der Fehler ist behoben. Mein Rat ist, dass Sie Notepad ++ (x86) installieren, wenn Ihr System x64 (64-Bit).

Ebenfalls ////

Enthaltene Plugins:

  1. NppExport v0.2.8 (nur 32-Bit x86)
  2. Plugin Manager 1.3.5 (nur 32-Bit x86)
  3. Konverter 4.2
  4. Mime Tool 2.1
0
lscodex

Der Versuch, den Plug-in-Manager wie in anderen Antworten beschrieben zu aktualisieren, hat das Problem für mich nicht gelöst und die "Installation von Compare fehlgeschlagen" wurde fortgesetzt.
Ich konnte das Plugin jedoch manuell installieren.

  • Laden Sie den Quellcode aus dem Github-Projekt herunter ,
  • verwenden Sie Visual Studio, um das Projekt zu erstellen
  • und kopieren Sie die kompilierten Artefakte in den Ordner\Notepad ++\plugins.
0
Andy Lam