it-swarm.com.de

Installation von TortoiseHg: Benötige eine höhere Mercurial Version

Ich benutze Ubuntu 11.04 und versuche TortoiseHg zu installieren. Ich habe das PPA von TortoiseHgs Website angewendet, damit apt-get es tatsächlich finden kann. Aber wenn ich Sudo apt-get tortoisehg eingebe, bekomme ich Folgendes:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 tortoisehg : Depends: Mercurial (>= 1.8) but 1.7.5-1ubuntu1 is to be installed
E: Broken packages

Ich verstehe, was das bedeutet: Ich muss Mercurial 1.8 installieren. Das Problem ist, dass ich nicht kann. Wenn ich Sudo apt-get install Mercurial versuche, heißt es, dass 1.7.5 die neueste Version ist, die es mit Sicherheit nicht ist .

Wie kann ich dieses Ding davon überzeugen, eine neuere Version von Mercurial zu installieren?

Ich habe die Befehle von diese Antwort ausprobiert, um Mercurial zu installieren, aber das hat nicht geholfen. Es wurde wieder gesagt, dass Mercurial auf dem neuesten Stand war.

8
Nicol Bolas

Verwenden Sie die Mercurial PPA

apt-add-repository ppa:Mercurial-ppa/releases
apt-get update 
apt-get install tortoisehg
10
tgm4883