it-swarm.com.de

Bilder werden im Blog nicht angezeigt

Heute Morgen werden die meisten Bilder in meinem WordPress-Blog (http://records.photodharma.net) nicht mehr geladen.

Dies geschieht sogar bei Einbettungen. Alle Bilder hier sind eingebettet: http://records.photodharma.net/photos/chiang-mai-photo-albums-of-modern-structures Wenn ich sie in Firebug ansehe, erscheinen sie, aber nicht auf der Seite.

Ein paar Mal habe ich gesehen, wie Bilder geladen wurden und kurz danach verschwanden. Es scheint also, dass sie versuchen zu laden, aber blockiert werden.

Ich habe einige Suchen durchgeführt und verschiedene Dinge ausprobiert, wie das Aktualisieren der Permalink-Einstellungen, der Medieneinstellungen usw. Ich habe auch auf die neueste Version von WordPress aktualisiert und die .htaccess-Datei aktualisiert, aber nichts hat funktioniert.

Hat jemand irgendwelche Ideen dazu?

1
Anandajoti

Ich habe eines der fehlenden Bilder auf einer anderen Registerkarte geöffnet und die Meldung "Verboten 403" wird angezeigt. Die Seite zeigt wie folgt:

403 Verboten

Sie dürfen nicht auf diese Seite zugreifen. Mögliche Probleme:

  • Fehlende Indexdatei
  • Falsch konfigurierte mod_rewrite-Einstellungen in .htaccess
  • Authentifizierungsfehler
  • Falsche Datei- oder Ordnerberechtigungen

Welche Gründe sind gültig, sollten Sie versuchen, zu überprüfen. Die Ordnerberechtigungen könnten die Antwort auf Ihr Problem sein. Wenn Sie jedoch keine besonderen Änderungen an Ihrem Server oder Blog-Administrator vorgenommen haben, ist die .htaccess-Datei möglicherweise die Lösung.

Das typische

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

sollte in Ihrem .htaccess sein. Und überprüfe, ob du mod_rewrite mit aktiviert hast

a2enmod rewrite

auf Ihrem Server. Hoffe das hilft.

1
javipas

Sprechen Sie mit Ihrem Host servage.net. Sie müssen einige Änderungen in ihrer Apache-Konfiguration vorgenommen haben, um Eigentümer/Berechtigungen des Kontos oder in mod_rewrite zu erhalten.

Dev Tools zeigt "Fehler beim Laden der Ressource: Der Server hat mit dem Status 403 (Verboten) geantwortet" an, was ein Problem auf Verzeichnisebene bedeutet, obwohl Sie die URL des direkten Bilds in einem neuen Fenster laden und anzeigen können.

0
markratledge

Das Seltsame, was ich hier sehe, ist, dass sie geladen werden, wenn Sie einen direkten Link zu ihnen erstellen.

http://photodharma.net/Blog/wp-content/themes/atahualpa/images/header/Bodhisatta-in-Tusita-Heaven.jpg

Vielleicht überprüfen Sie Ihre Berechtigungen? Stellen Sie sicher, dass die Ordner und Dateien über die entsprechenden Berechtigungen verfügen. Ehrlich gesagt ist es eine Vermutung, da ich nicht glaube, dass wir sie durch direkten Link sehen könnten, wenn die Berechtigungen falsch wären.

0
Tom

Wenn das Bild direkt von photodharma.net geladen wird, aber nicht von records.photodharma.net, dann habe ich den Verdacht, dass Sie Hotlinking deaktiviert haben.

Haben Sie irgendwelche Hotlink-Verhinderungsregeln für Ihre .htaccess-Datei? Haben Sie Plugins aktiviert, die ein Hotlinking verhindern?.

Hinweis: Wenn das Problem die Verhinderung von Hotlinks ist, müssen Sie .htaccess und Plugins auf photodharma.net , not auf records.photodharma.net.

EDIT

Wenn Sie nirgendwo einen Hotlink-Schutz haben, sind die Datei-/Ordner-Berechtigungen wahrscheinlich der nächste Schuldige.

Was sind die Berechtigungen für http://www.photodharma.net/Blog/images/?

0
Chip Bennett