it-swarm.com.de

Bild-URLs funktionierten aufgrund von Permalinks nicht mehr?

Ich habe meine Permalinks geändert und meine Website in die "www" -Version geändert (was meiner Meinung nach meine Bild- und Videolinks beschädigt hat). Alle meine Bilder sind jetzt "rot x", sowohl in der Bibliothek als auch in den Beiträgen. Ich habe in meinem cpanel nachgesehen und alle Dateipfade sind korrekt, aber wenn ich versuche, sie durch WP anzuzeigen oder einfach die URL zu kopieren und sie in meinem Browser zu testen, scheint sie fehlerhaft zu sein.

Gibt es eine Möglichkeit, dies zu beheben? Abgesehen davon, dass Sie alles neu laden, sichern Sie es. :-(

Zum Aktualisieren: Ich habe gerade ein Bild erneut hochgeladen und es wurde als header1.png gespeichert, sodass WP sehen kann, dass sich dort ein anderes Bild befindet. Es ist seltsam, weil alle Pfade in meiner Bibliothek mit denen in cpanel übereinstimmen.

Ich glaube, weil ich die Permalink-Struktur auf% category% /% postname% geändert habe, hat dies Auswirkungen auf die Bildstruktur, die aus wp-content/uploads /% year% /% month% /% imagename% besteht.

1
Jonnny

wenn Sie mit Ihrer WWW-Struktur Affen haben, können Sie die Bild-URLs (da sie im img src fest codiert sind) mit dem folgenden Plugin ändern:

http://wordpress.org/extend/plugins/velvet-blues-update-urls/

1
helgatheviking

Ich hatte ein ähnliches Problem und konnte nur Folgendes beheben:

  • Kopieren Sie das Problembild in dasselbe Verzeichnis.
  • Löschen Sie das Original
  • Benennen Sie die kopierte Datei in den ursprünglichen Namen um.

Nehmen wir an, es heißt "xyz.jpg". Sobald Sie es kopiert haben, erhalten Sie "xyz - copy.jpg".

Entfernen Sie die Datei "xyz.jpg" und benennen Sie die Datei "xyz-copy.jpg" in "xyz.jpg" um.

Ich bin mir ziemlich sicher, dass es nicht die beste Lösung ist. Aber es hat bei mir geklappt.

0
curiousBoy