it-swarm.com.de

Holen Sie sich IIS, um .NET Framework> 4.6 zu verwenden

Ich habe einen neu installierten Win Server 2016 mit "IIS 10" installiert (durch "Funktionen hinzufügen" ->/guide/-> IIS installieren ankreuzen ")

Wenn ich mir meine App-Pools ansehe, sehe ich, dass sie ".NET CLR Version" 4.0 haben und meine Apps v4.6.x verwenden. Ich kann nicht zu anderen Versionen in der Dropdown-Liste wechseln.

Wenn ich die Win-Registrierung überprüfe (mit diese Anleitung ) bei

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework-Setup\NDP\v4\Full

Ich erhalte die Nummer für .NET Version 4.7. Wie aktualisiere ich meine IIS/App-Pools, um .NET FW> 4.0 zu unterstützen? Dies ist ein Produktionsserver, daher möchte ich nicht mit dem Herunterladen von und beginnen Pakete wohl oder übel hier installieren.

6
Cowborg

IIS und seine App-Pools unterstützen bereits 4.7. Sie benötigen oder können nichts dagegen tun.

Denken Sie an .NET CLR Version 4.0, Um tatsächlich .NET CLR Version 4.x Zu bedeuten. Auf Ihrem Computer ist nur eine einzige CLR 4 installiert, und IIS verwendet sie.

Sie müssen nichts tun, Ihre Anwendung sollte einwandfrei funktionieren.

8
Peter Hahndorf