it-swarm.com.de

xrandr: Fehler beim Abrufen der Größe des Gammas für die Standardausgabe "für Verbindungen vom Typ mDP

Meine Systemspezifikationen:

  • Intel i7-8700k (Kaffee-See)
  • Hauptplatine: ROG (Maximus X Hero)
  • Betriebssystem: Ubuntu-Gnome 16.04

Ich habe meinen neuen PC mit Ubutnu-Gnome 16.04 gestartet, nach der Installation beträgt die Bildschirmauflösung 1024x768 (4: 3) und auf dem Bildschirm wird Unknown Display angezeigt. Ich habe auf meinem neuen Betriebssystem nichts installiert. Mein Monitor-CPU-Verbindungskabel ist ein DP (Pin-Kabel).

Ich habe es mit "Force create new resolution" versucht:

  1. cvt 1366 768 60
  2. xrandr --newmode "< >"

Dann tritt ein Fehler auf:

xrandr : Failed to get size of gamma for output default

Ich möchte, dass die perfekte Auflösung für meinen Desktop-Bildschirm geeignet ist.

Kann mir jemand bei diesem Problem helfen?

3
Harish Bodduna

Hier gilt das gleiche...

CPU: Intel i3-8350k (Coffee-Lake) Mobo: MSI z370 Gaming M5 Betriebssystem: Ubuntu 17.10

EDIT

Basierend auf Informationen in diesem Artikel Ich habe Antwort gefunden.

Sie müssen "i915.alpha_support=1" Boot-Parameter zu GRUB hinzufügen (Info von hier ):

  1. Melden Sie sich am System an und starten Sie ein Terminalfenster (Applications->Accessories->Terminal).

  2. Geben Sie im Terminalfenster an der Eingabeaufforderung $ den folgenden Befehl ein: Sudo gedit /etc/default/grub

  3. Geben Sie Ihr Passwort ein, wenn Sie von [Sudo] dazu aufgefordert werden. (Wenn die Datei/etc/default/grub leer zu sein scheint oder nicht existiert, lesen Sie die Anweisungen für frühere Versionen oben).

  4. Verwenden Sie im Editorfenster die Pfeiltasten, um den Cursor auf die Zeile zu bewegen, die mit "GRUB_CMDLINE_LINUX_DEFAULT" beginnt. Bearbeiten Sie dann diese Zeile und fügen Sie Ihre Parameter dem Text in Anführungszeichen nach den Wörtern "quiet splash" hinzu. . (Fügen Sie nach "splash" unbedingt ein Leerzeichen hinzu, bevor Sie Ihren neuen Parameter hinzufügen.)

es sollte so aussehen "quiet splash i915.alpha_support=1"

  1. Klicken Sie auf die Schaltfläche Speichern und schließen Sie das Editorfenster.

  2. Geben Sie im Terminalfenster an der Eingabeaufforderung $ den folgenden Befehl ein: Sudo update-grub.

  3. Starten Sie das System neu.

Ich hoffe es klappt bei dir;)

3
marekbrze