it-swarm.com.de

Wie kann ich fehlende Zeichen in der Schrift nach dem Aufwachen aus dem Suspend beheben?

Ich stelle fest, dass ich nach dem Aufwachen aus dem Suspend unter Ubuntu GNOME 16.04 mit GNOME 3.20 (ich habe dieses Problem nur in der neuesten Version gefunden, obwohl ich es unter GNOME 3.18 mit 16.04 nicht ausprobiert habe) dieses seltsame Schriftartproblem bekomme, das nicht sein kann Behoben durch einen Neustart von gnome-Shell und scheinbar nur durch einen Neustart meiner gesamten Maschine:

gnome-system-monitor font issue

Shutter font issue

File Chooser font issue

Title Bar font issue

gnome-control-center font issue

Ich glaube nicht, dass dies ein Thema ist, da ich alle integrierten Themen ausprobiert habe (einschließlich der dunklen und hellen Versionen) und es für alle gleich ist. Obwohl dies keine Auswirkungen auf gnome-Shell Bereiche zu haben scheint, sind die obere Leiste, die Aktivitätenübersicht usw. aus irgendeinem Grund nicht betroffen. Woran kann dieses Problem liegen und wie kann es behoben oder umgangen werden?

Aktualisierung der Informationen:

Ich habe mir diese Antwort angesehen, aber die einzigen Optionen in gnome-Tweak-tool für Antialiasing sind Rgba, None und Grayscale, aber keiner von ihnen scheint Einfluss auf das Problem zu haben. Fehlt mir etwas?

46
user364819

Dies könnte ein Symptom für einen Kernel-Fehler seit 4.4.6 sein, siehe hier der Berichten zufolge in Linux-Kernel 4.8.x behoben wurde, und der Fix wird in Ubuntu 17.04 (der wahrscheinlich 4.10-Kernel haben wird) sein.

Auf Fedora Bug Tracker hilft jemand gemeldet , der dies in /etc/X11/xorg.conf.d/20-intel.conf ändert/hinzufügt:

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "blt"
   Option      "TearFree"     "true"
EndSection

Ich habe es nicht versucht, ich werde bis zum 17.04 warten.

Bei mir passiert das auch nach dem Wechsel zu einem anderen Benutzerkonto und wieder zurück.

8
Ondra Žižka

Wenn mein Ubuntu bei der Wiederherstellung nach dem Suspend Anzeigeprobleme hat, behebe ich dies mit einem kurzen Besuch der Konsole: Ctrl+Alt+F1.

Warten Sie einige Sekunden, wenn Ihr Display blinkt, die Auflösung ändert usw. Dann zurück: Ctrl+Alt+F7.

1

Umgehung, verwende Kernel 4.8:

Sudo apt install linux-generic-hwe-16.04

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1573959

1
mr.xkr

Ich hatte dieses Problem und stellte aus irgendeinem Grund fest, dass mein Laptop eine alte Kernel-Version (4.4 anstatt 4.15) verwendete. Ich bin am 18.04, nachdem ich ein Upgrade von 16.04 durchgeführt habe.

Ich habe den neuesten Kernel installiert:

Sudo apt-get install linux-image-generic

Das hat das Problem behoben.

0
Andy Triggs