it-swarm.com.de

Google Chrome startet nicht - Theme-Engine kann in module_path nicht gefunden werden: "adwaita"

Google Chrome startet nicht nach einem apt-get upgrade. Ich kann nicht herausfinden, was ich vermisse, und Google liefert nicht viele Ergebnisse für diese Fehler:

$ google-chrome
[1:1:0518/085616:ERROR:image_metadata_extractor.cc(111)] Couldn't load libexif.
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "adwaita",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "adwaita",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
[5807:5807:0518/085616:ERROR:browser_main_loop.cc(199)] GTK theme error: Unable to locate theme engine in module_path: "pixmap",
Aborted (core dumped)


$ google-chrome --version
Google Chrome 42.0.2311.152

Chrome funktionierte auf diesem Computer vor dem Upgrade einwandfrei.

5
mkasberg

Das Problem scheint nur mit der i386-Version von Google Chrome auf einem 64-Bit-Ubuntu-System aufzutreten. Der Hinweis, dass es sich um ein 32-Bit- oder 64-Bit-Problem handelte, war, dass bei der Installation der :i386 -Version bestimmter Pakete einige Fehler behoben wurden. Ich konnte Chrome wieder zum Laufen bringen, indem ich die 64-Bit-Version installierte:

$ Sudo aptitude install google-chrome-stable

The following packages have unmet dependencies:
 libappindicator1 : Conflicts: libappindicator1:i386 but 12.10.1+15.04.20141110-0ubuntu1 is installed.
 libappindicator1:i386 : Conflicts: libappindicator1 but 12.10.1+15.04.20141110-0ubuntu1 is to be installed.
 google-chrome-stable : Conflicts: google-chrome-stable:i386 but 42.0.2311.152-1 is installed.
 google-chrome-stable:i386 : Conflicts: google-chrome-stable but 42.0.2311.152-1 is to be installed.
 libindicator7 : Conflicts: libindicator7:i386 but 12.10.2+14.10.20140922-0ubuntu1 is installed.
 libindicator7:i386 : Conflicts: libindicator7 but 12.10.2+14.10.20140922-0ubuntu1 is to be installed.
The following actions will resolve these dependencies:

     Remove the following packages:
1)     google-chrome-stable:i386   
2)     libappindicator1:i386       
3)     libindicator7:i386          

Accept this solution? [Y/n/q/?] 

Ich habe die vorgeschlagene Lösung zum Upgrade mehrerer Pakete auf die 64-Bit-Version akzeptiert und Chrome funktioniert wieder.

1
mkasberg

Der erste Teil meiner Antwort:

Für GTK theme error: Unable to locate theme engine in module_path: "pixmap"

Sudo apt-get install  gtk2-engines-pixbuf:i386
3
A.B.

Ich hatte das gleiche Problem und mkasberg hatte die Lösung - 32bit zu deinstallieren und 64bit neu zu installieren. Ich war zu google.com/chrome gegangen und hatte die 64-Bit-.deb-Datei wie gewohnt heruntergeladen. Ich habe die .deb-Datei ausgeführt und google-chrome-stable wurde im Software Center geöffnet. Installierte es, was gut lief, aber es stellt sich heraus, dass google-chrome-stable: i386 wurde stattdessen installiert.

$ Sudo apt-get remove google-chrome-stable:i386
$ Sudo apt-get install google-chrome-stable
0
Ross Hodapp

Ich kann die Anwendung nicht immer aktualisieren, das hat bei mir funktioniert

$ Sudo apt install gnome-themes-standard:i386
0
Herman