it-swarm.com.de

So installieren Sie Firefox 32-Bit ESR 52 ohne Deinstallation von Firefox 64-Bit unter 16.04

Mein Computer verfügt über Ubuntu 16.04.2 LTS 64-Bit und Firefox 52 64-Bit.

Für eine der Regierungswebsites muss Folgendes installiert werden, da das Browser-Plugin Java zum Signieren von Dokumenten verwendet wird:

  1. Firefox ESR 52 . Gewöhnliches Firefox 52 unterstützt Java nicht mehr als Browser-Plugin, da NPAPI entfernt wurde ( Quelle ).
  2. Firefox ESR 52 32-Bit . Ich weiß sicher, dass Firefox 32-Bit nur Sun Java unter Windows unterstützt, aber ich bin mir nicht sicher, ob dies auch eine Einschränkung für Ubuntu ist. Wenn ja, benötige ich die 32-Bit-Version von Firefox und nicht die 64-Bit-Version von Firefox. 2

Ich weiß, dass ich Firefox 32-Bit wie folgt installieren kann:

  1. installieren Sie Firefox 32-Bit im Terminal:

    Sudo apt install firefox:i386
    

    wenn Sie jedoch Firefox 32-Bit installieren, wird Firefox 64-Bit deinstalliert, was ich gerne beibehalten würde.

  2. laden Sie Firefox 52 ESR 32-Bit von 2 herunter und extrahieren Sie es.

Gibt es eine andere Möglichkeit, Firefox ESR 52 32-Bit und Sun Java 32-Bit unter Ubuntu 16.04.2 LTS 64-Bit zu installieren, ohne Firefox 52 64-Bit zu deinstallieren?

Sehen:

  1. Plug-in-Unterstützung wurde außer Flash entfernt
  2. Download der Firefox Extended Support-Version

Vielen Dank

7
folow

Bitte versuchen Sie diese Problemumgehung. Für mich waren die Plugins wie Java und VLC danach wieder da. Ich verwende buntu 16.04 64 Bit mit Mozilla Firefox 64 Bit Version 52 (nicht ESR) und Java JDK 1.8.0_112

  1. Öffnen Sie Firefox und geben Sie about: config in die Adressleiste ein und drücken Sie die Eingabetaste
  2. Klicken Sie auf "Ich akzeptiere das Risiko!"
  3. Klicken Sie mit der rechten Maustaste auf eine beliebige Stelle und wählen Sie Neu> Boolean
  4. Geben Sie plugin.load_flash_only in das angezeigte Feld ein
  5. Setzen Sie den Wert auf false
  6. Löschen Sie alle Verlauf und Neustart Firefox

Ich benutze auch verschiedene Regierungswebsites, die das Java-Plugin und digitale Signaturen verwenden.

Versuchen Sie dies und lassen Sie es mich wissen.

Bearbeiten: Mozilla Firefox 53 entfernt das Flag plugin.load_flash_only, sodass diese Problemumgehung nicht mehr funktioniert.

Pale Moon Das Webbrowserteam hat angekündigt, die Unterstützung von NPAPI-Plugins auf unbestimmte Zeit fortzusetzen. Um das Java Plugin in Pale Moon zu installieren, führen Sie dieses im Terminal aus

Sudo ln -s /usr/lib/Java/jdk1.8.0_121/jre/lib/AMD64/libnpjp2.so /usr/lib/mozilla/plugins/libnpjp2.so

Ich habe das Java Plugin im Pale Moon Browser getestet. 100% arbeiten.

8
Lijin

Ich benutze 16.04 LTS 64-Bit
Ich lade und entpacke Firefox 64-Bit (aber ältere Version - v.45) von hier https://www.mozilla.org/en-US/firefox/organizations/all/ =
Danach schließe ich meinen 'Standard'-Firefox und starte die' Firefox'-Datei aus dem extrahierten Ordner des Archivs der Version 45.
Also öffne ich meine Site und führe die Anwendung Java darin erfolgreich aus.

P.S.
Ich habe auch Java auf die neueste Version aktualisiert:

Sudo add-apt-repository ppa:webupd8team/Java
Sudo apt-get update
Sudo apt-get install Oracle-Java8-installer
2
Rib47

Sie können eine neue Version in einem lokalen Ordner installieren (z. B. ~/applications/firefox_esr/), sie können jedoch nicht gleichzeitig ausgeführt werden. Nach dem, was ich gelesen habe Firefox-Website , hat die Linux-Version nicht die gleiche Einschränkung wie die Windows-Version. Verwenden Sie einfach die 64-Bit-Version des ESR.


Ich hatte ein ähnliches Problem, aber das oben Genannte reichte nicht aus, um das Problem mit dem Java Plugin zu lösen. Wenn Sie das nicht schaffen, installieren Sie SeaMonkey 2.46 (64-Bit) und versuchen Sie es erneut.

0
Alexandre