it-swarm.com.de

Fedora 29: Fehler beim Synchronisieren des Cache für das Repo 'Fedora-modular'

Ich habe Fedora 27 auf 28 aktualisiert, ein wenig damit gearbeitet (kein dnf-Update ausgeführt) und dann auf 29 aktualisiert. Heute Morgen habe ich es versucht

Sudo dnf -v update

und ich bekam

 Sudo dnf -v update 
 Geladene Plugins: builddep, config-manager, copr, debug, debuginfo-install, download, generate_completion_cache, Neustart der Bedürfnisse, Spielplatz, Wiedereinschaltung, Repodiff, Repograph, Repomanage, Reposync, System-Upgrade 
 DNF-Version: 4.0.9 
 Cachedir: /var/cache/dnf[.____.‹Unbekannter Konfigurationswert: Failover-Methode = Priorität in /etc/yum.repos.d /Fedora-Cisco-openh264.repo; Konfiguration: OptionBinding mit der ID "Failover-Methode" existiert nicht 
 Unbekannter Konfigurationswert: Failover-Methode = Priorität in /etc/yum.repos.d/Fedora-modular.repo; Konfiguration: OptionBinding mit der ID "Failover-Methode" existiert nicht 
 ... 
 Repo: Herunterladen von Remote: Fedora-modular 
fehler: Curl-Fehler (60): Das Peer-Zertifikat kann nicht mit den angegebenen CA-Zertifikaten für https://mirrors.fedoraproject.org/metalink?repo=Fedora-modular-29&Arch=x86_64 authentifiziert werden. [SSL-Zertifikatsproblem: Selbstsigniertes Zertifikat in der Zertifikatskette ]] (https://mirrors.fedoraproject.org/metalink?repo=Fedora-modular-29&Arch=x86_64).[.____.‹Fedora Modular 29 - x86_64 0.0 B/s | 0 B 00:01 
 'Https://mirrors.fedoraproject.org/metalink?repo=Fedora-modular-29&Arch=x86_64' kann nicht heruntergeladen werden: Interne Spiegelliste kann nicht vorbereitet werden: Curl-Fehler (60): Peer-Zertifikat nicht möglich mit den angegebenen CA-Zertifikaten für https://mirrors.fedoraproject.org/metalink?repo=Fedora-modular-29&Arch=x86_64 [SSL-Zertifikatsproblem: Selbstsigniertes Zertifikat in der Zertifikatkette] authentifiziert werden. 
 Fehler: Fehler Cache für Repo 'Fedora-modular' synchronisieren 
 

Das eigentliche Problem sieht so aus

[SSL certificate problem: self signed certificate in certificate chain]

Die Datei ca-bundle.crt enthält Links zu tls-ca-bundle.pem und dieser Datei

205488 Dec 11 14:14 /etc/pki/ca-trust/extracted/pem/tls-ca-bundle.pem

wurde aktualisiert.

Ich habe gerade ein Upgrade auf eine Version durchgeführt, die ich nicht aktualisieren kann.

7
Jim

Dies kann mehrere Gründe haben. Erstens haben Sie möglicherweise nicht die erforderlichen Schlüssel (passiert manchmal). Die Lösung besteht darin, das Paket mit den Schlüsseln von Hand zu installieren. Oder es kommt einfach vor, dass Sie den Spiegel in einem inkonsistenten Zustand abfangen oder das Repository aktualisiert wird. Wenn Sie einen dnf update --refresh Ausführen, werden solche Probleme normalerweise behoben. Wenn nicht, versuchen Sie es in einigen Stunden erneut.

1
vonbrand