it-swarm.com.de

Das Upgrade des Plugins "Kategorie-Beiträge auflisten" schlägt mit schwerwiegendem Fehler fehl

Ich habe gerade versucht, ein automatisches Upgrade von List Category Posts Plugin auf Version 0.17.2 unter WordPress 3.0.5 durchzuführen. Ich glaube ich hatte vorher 0.17.1. Es wurde installiert, konnte jedoch nicht aktiviert werden:

Plugin could not be activated because it triggered a fatal error.
Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /hsphere/local/home/carrollp/clanecommunity.ie/wp-content/plugins/list-category-posts/include/CatListDisplayer.php on line 10

Wenn ich richtig verstehe, hat der Autor angefordert Probleme hier gepostet.

Ich habe WordPress noch nie zuvor getestet. Schätzen Sie jede Hilfe. Meine Homepage basiert auf diesem Plugin. Vielen Dank!

2
jmkie

Ja, ich habe darum gebeten, dass hier Probleme gemeldet werden, damit Sie Antworten von der größeren Community der WordPress-Benutzer und -Entwickler bei WordPress Answers erhalten.

In Bezug auf das Problem wurde es auch von einem anderen Benutzer gemeldet. Dies liegt daran, dass der Webhost PHP verwendet. In Zeile 10 von CatListDisplayer.php wird ein privates Attribut deklariert. PHP 4 hat keine öffentlichen, privaten oder geschützten Accessoren.

Gibt es eine Möglichkeit, Ihren Webhosting-Anbieter aufzufordern, Ihren Server auf PHP 5 zu aktualisieren?

Die andere mögliche Lösung ist das Herunterladen der vorherigen Version des Plugins: 0.16, die kein objektorientiertes PHP verwendet.

2
Fernando Briano