it-swarm.com.de

Wie installiere ich glib?

Ich möchte die Empathie in Ubuntu 11.04 erstellen. Wenn ich den Build-Prozess verfolge,

 ./autogen.sh

Die Shell hat mir das gesagt

libtoolize: copying file `m4/lt~obsolete.m4'
checking for autoconf >= 2.53...
testing autoconf2.50... not found.
testing autoconf... found 2.67
checking for automake >= 1.9...
testing automake-1.11... found 1.11.1
checking for libtool >= 1.5...
testing libtoolize... found 2.2.6b
checking for glib-gettext >= 2.2.0...
testing glib-gettextize... not found.
***Error***: You must have glib-gettext >= 2.2.0 installed
to build Empathy.  Download the appropriate package for
from your distribution or get the source tarball at
ftp://ftp.gtk.org/pub/gtk/v2.2/glib-2.2.0.tar.gz

Aber wenn ich keinen Weg finde, glib zu installieren. Was soll ich tun, um das in Ubuntu 11 zu installieren?

38
user8260

Sie benötigen libglib2.0-dev für glib-gettext. Sie können es mit installieren

Sudo apt-get install libglib2.0-dev
84
binW

sie müssen auch libgtk2.0-dev installieren, um glib vollständig zu installieren (glib ist ein Teil von: libgtk2.0-dev)

Sudo apt-get install libgtk2.0-dev

weitere Erklärungen finden Sie unter diesem Link: Installieren von gtk und glib

5
Ali.A

Ich empfehle Ihnen, nach verfügbaren PPAs zu suchen, wenn Sie nur die neuere Empathie überprüfen möchten, als Sie haben. Ich denke das ppa ist die beste Wette Oder mach das einfach

Sudo add-apt-repository ppa:telepathy/ppa

Oder wenn Sie es bauen müssen.

Sudo apt-get build-dep empathy

dadurch werden alle Abhängigkeiten installiert, die zum Aufbau von Empathie aus dem Quellcode erforderlich sind.

3
sagarchalise