it-swarm.com.de

Eclipse WTP-Plugin ohne Apache Tomcat-Adapter

Ich verwende Galileo Eclipse, ich habe WTP-Plugin heruntergeladen, aber kein Apache Tomcat-Plugin, wenn ich versuche, einen Tomcat-Server hinzuzufügen ...

eine schnelle idee?

45
d-man

In WTP können Sie Plugins für viele verschiedene Webcontainer- oder Java EE-Anwendungsserver herunterladen.

Gehen Sie dazu zu Window => Preferences => Server => Runtime Environments => Add... Wählen Sie die Server aus, mit denen Sie arbeiten möchten.

Wie Raghuram jedoch betonte, wäre es wahrscheinlich besser, wenn Sie von "Eclipse for Java EE-Entwicklern" ausgehend starten. Dies liegt daran, dass WTP auf vielen "Infrastruktur" -Plugins wie EMF aufbaut und die Abhängigkeiten manchmal wacklig sind, da sich all diese Plugins parallel entwickeln ... und meistens nicht, API-Änderungen.

8
Alain Pannetier

Abhängig von der Installation haben Sie möglicherweise die Funktionen "JST Server Adapters" (org.Eclipse.jst.server_adapters.ext) und "JST Server Adapters Extensions" übersprungen, die die Unterstützung von Apache Tomcat tatsächlich enthalten.

136
nitind

Ich habe das gleiche Problem schon einmal getroffen, aber meine Eclipse ist Indigo und auch WTP wurde heruntergeladen ... oderz kein Tomcat gefunden. Ich entschied mich jedoch folgendermaßen:

  1. Gehen Sie zu Hilfe> Neue Software installieren ...
  2. Wählen Sie in der Arbeit mit "Indigo - http://download.Eclipse.org/releases/Indigo " aus.
  3. Wählen Sie in der Liste "Web-, XML- und Java EE-Entwicklung" aus.
  4. Wählen Sie dann "JST-Serveradapter" aus.

Nach der Installation, wenn ich einen neuen Server hinzufüge, kann ich sehen, dass Tomcat zur Auswahl steht. :) hoffe das hilft auch ~

32
sibley

Vergewissern Sie sich, dass " JST Server Adapters Extensions " ebenfalls installiert ist. Tomcat erschien nicht für mich, bis ich dieses Plugin installiert habe.

19
ccallendar

Ich hatte das gleiche Problem. Ich habe @sibley-Lösung verwendet, aber Tomcat8.5 und höher fehlten. Um dies zu korrigieren, musste ich auf Hilfe> Auf Update prüfen klicken. Dies wird alle fehlenden Tomcat bringen

0
onlyme