it-swarm.com.de

Ubuntu Dual Boot mit Legacy Windows 10: Kann nach der Installation eines von beiden booten, aber nicht beide

Ich bin neu in Linux und habe gestern versucht, mein erstes Ubuntu als Dual-Boot mit den bereits vorhandenen Windows 10 zu installieren. Allerdings hatte ich einige Probleme. Nach der Installation von Ubuntu Windows automatisch gestartet, ohne mir eine Dual-Boot-Option zu geben. Der Windows-Bildschirm war durcheinander (auf meinem Bildschirm wurden 2 abgeflachte Fenster angezeigt), als würde er die Bildschirmgrößen von Ubuntu in meiner Windows-Installation verwenden. Dann habe ich versucht, Ubuntu über ein Flash-Laufwerk zu starten. Dabei habe ich die Option 'ubuntu testen' verwendet und eine Boot-Reparatur durchgeführt. Jetzt startet Ubuntu automatisch, ohne mir die Möglichkeit zu geben, Windows zu starten.

Was ich schon ausprobiert habe:

  • Vor der Installation von ubuntu habe ich sichergestellt, dass der sichere Start und der Schnellstart deaktiviert sind
  • Ich habe vor der Installation von Ubuntu sichergestellt, dass alle Boot-Optionen im BIOS auf den Legacy-Modus eingestellt waren, da sich mein Windows anscheinend im Legacy-Modus befindet (siehe unten).
  • Ich habe sichergestellt, dass CSM in meinem BIOS aktiviert ist
  • Ich habe nach Möglichkeiten gesucht, die Startreihenfolge zu ändern, aber nur ein bootfähiges Gerät ist aufgeführt
  • Ich habe versucht, Ubuntu als UEFI zu installieren, was dazu führte, dass mein PC überhaupt nicht mehr bootete. Ich habe nur eine Fehlermeldung ausgegeben (obwohl dies möglicherweise etwas mit der Installation als Ext2 zu tun hatte?) Und musste Windows neu installieren und neu starten

Was ich weiß:

  • Windows wird im Legacy-Modus angezeigt (und bereits zuvor angezeigt). Ich gehe davon aus, dass das Ubuntu-Installationsprogramm angibt, dass ich ein System im Legacy-Modus habe (und daher Ubuntu auch im Legacy-Modus installiert habe). Auch wenn ich ins BIOS gehe, geht es um BIOS-Optionen und dergleichen. Ich stelle mir vor, wenn ich (u) efi verwende, würde es nicht um BIOS gehen. EDIT: Ich muss dies ein wenig korrigieren, der Titel meines BIOS ist "UEFI Dual BIOS"
  • Meine Windows-Version ist Windows 10 Education 32/64 Bit
  • Ich kann von Ubuntu aus auf das Windows 10-Laufwerk zugreifen und die Dateien in der Windows-Partition anzeigen
  • dateisystem für Ubuntu-Partition ist Ext4

Ich verbrachte anderthalb Tage fast ganztägig damit, dies zu beheben. Ich habe so gut ich konnte gegoogelt und alle Ratschläge ausprobiert, die mir vernünftigerweise Sinn machten, und ich bin der Behebung des Problems nicht einen Schritt näher gekommen (außer dass ich weiß, welche Lösungen meiner Meinung nach nicht funktionieren: P). Ich könnte deine Hilfe gebrauchen! Wenn weitere Informationen benötigt werden, lassen Sie es mich bitte wissen.

Bearbeiten: Einige Informationen zu meinem Bios-Typ wurden korrigiert. Weitere Informationen finden Sie im Abschnitt "Was ich weiß"

Edit2: das Boot Repair Pastebin wie gewünscht: http://paste2.org/V8DcV65J

Edit3: Versuchte etwas Neues, da ich irgendwann in der Lage war, in Windows zu booten, dachte ich, mein Problem könnte dem dieses Typen ähnlich sein: Kann in Ubuntu oder Windows booten, aber nicht in beiden Stellt sich heraus das war falsch: P Um den sicheren Start zu aktivieren, musste ich CSM deaktivieren, was es mir unmöglich machte, Windows oder Ubuntu zu starten. Ich habe es gerade beim Start direkt in das BIOS geladen (unabhängig davon, ob ich den sicheren Start aktiviert habe oder nicht). Auch die Lösung, die für ihn funktioniert hat, ist für mich völlig unmöglich (ich sehe das Kontrollkästchen nicht)

Bemerkenswert ist auch, dass ich beim Start in Grub lade (wenn CSM natürlich aktiviert ist), dass ich nur zwischen Ubuntu, erweiterten Optionen für Ubuntu und System-Setup wählen kann. Ich habe auch versucht, beim Start f12 zu drücken (lädt Sie in die Boot-Optionen), aber da habe ich das Problem, dass es mir nur meine Festplatte gibt, also eine Option, in die ich laden kann, und nicht die beiden Partitionen.

edit4: es kann nichts sein, aber in Grub, wenn ich die System-Setup-Option wähle, heißt es: Fehler: Befehl fwsetup kann nicht gefunden werden.

2
Hasse Iona

Ein Freund hat die Lösung für mich gefunden! Es stellte sich heraus, dass die Lösung darin bestand, grub zu aktualisieren:

Sudo grub-mkconfig -o /boot/grub/grub.cfg

wie in diesem Beitrag zu finden: Dual-Boot lädt Windows nicht mehr

0
Hasse Iona

Vielleicht ist es etwas mit GRUB. Versuchen Sie, beim Starten des Computers die Umschalttaste gedrückt zu halten. Halten Sie ggf. die Leertaste oder die Esc-Taste gedrückt. In diesen Trheads gibt es andere Möglichkeiten, das Menü GRUB beim Start zu aktivieren Link1 , Link2

Haben Sie versucht, sichere Startschlüssel auf dem USB-Stick zu speichern und Plattformschlüssel in Ihrem UEFI zu löschen? Tutorial für ASUS-Motherboards

UEFI-basiertes Material verfügt über viele Standardoptionen, die bei der Installation anderer Betriebssysteme Fehler verursachen. Haben Sie versucht, den Bootloader auf einer anderen Partition zu installieren? In meinem Fall - 1 SSD mit Windows-Bootloader und ein anderes Laufwerk mit Ubuntu-Bootloader hat nicht funktioniert. es zeigten sich nur Fenster und es gab keinen GRUB. Aber als ich den Bootloader auf dem gleichen Laufwerk wie Windows installiert habe, hat es funktioniert.

0
Piteight