it-swarm.com.de

Wie kann der mit dem Befehl Drush Composer angezeigte Fehler DL behoben werden?

Ich arbeite an MAMP und habe bereits eine Drupal 7-Site auf meinem lokalen Computer installiert (ohne Drush oder Composer). Dann habe ich Composer und Drush installiert ( Drush auf MAMP installieren ). Jetzt befindet sich meine Drupal Site im Ordner htdocs und funktioniert. Wenn ich "drush" von htdocs über die Befehlszeile ausführe, wird eine Reihe von Hilfebefehlslisten angezeigt.

Wenn ich jedoch versuche, ein Modul mit drush dl Module_Name Zu installieren, wird folgende Fehlermeldung angezeigt:

[Fehler] dl ist veraltet. Bitte erstellen Sie Ihre Site mit Composer. Fügen Sie neue Projekte mit composerhinzu. _ Drupal/[Projektname] erforderlich. Verwenden Sie https://www.drupal.org/project/composer_generate , um eine composer.json zu erstellen, die die aktivierten Module auf Ihrer Site darstellt.

Kann mir jemand sagen, wo das Problem liegt? Muss ich eine neue Drupal 7-Site über Composer installieren?

3
Sue

using composer ist eher für Drupal 8 als Drupal 7) Sie können Ihre Version entfernen:

composer global remove drush/drush

und installieren Sie eine ältere

composer global require drush/drush:8.*
1
MarJu