it-swarm.com.de

Wie behebe ich diesen Installationsfehler?

Ich erhalte die folgende Fehlermeldung bei der Installation von Drush mit composer require drush/drush.

Verwenden von Version ^ 8.1 für Drush/Drush
./ composer.json wurde aktualisiert
Laden composer Repositorys mit Paketinformationen
Aktualisieren von Abhängigkeiten (einschließlich require-dev)
Ihre Anforderungen konnten nicht in einen installierbaren Satz von Paketen aufgelöst werden.

Problem 1
- drush/drush 8.1.0 kollidiert mit drupal/drupal [Keine Version festgelegt (analysiert als 1.0.0)].
- drush/drush 8.1.1 Konflikte mit drupal/drupal [Keine Version festgelegt (analysiert als 1.0.0)].
- drush/drush 8.1.2 Konflikte mit drupal/drupal [Keine Version festgelegt (analysiert als 1.0.0)].
- drush/drush 8.1.3 Konflikte mit drupal/drupal [Keine Version festgelegt (analysiert als 1.0.0)].
- drush/drush 8.1.4 Konflikte mit drupal/drupal [Keine Version festgelegt (analysiert als 1.0.0)].
- drush/drush 8.1.5 Konflikte mit drupal/drupal [Keine Version festgelegt (analysiert als 1.0.0)].
- drush/drush 8.1.6 Konflikte mit drupal/drupal [Keine Version festgelegt (analysiert als 1.0.0)].
- drush/drush 8.1.7 Konflikte mit drupal/drupal [Keine Version festgelegt (analysiert als 1.0.0)].
- drush/drush 8.1.8 Konflikte mit drupal/drupal [Keine Version festgelegt (analysiert als 1.0.0)].
- drush/drush 8.1.9 Konflikte mit drupal/drupal [Keine Version festgelegt (analysiert als 1.0.0)].
- Fazit: Drush/Drush 8.1.12 nicht installieren
- Fazit: Drush/Drush 8.1.11 nicht installieren
- Fazit: Drush/Drush 8.1.10 nicht installieren
- Fazit: Installieren Sie drush/drush 8.x-dev nicht
- Installationsanforderung für Drupal/Drupal [Kein Versionssatz (analysiert als 1.0.0)] -> Erfüllbar durch Drupal/Drupal [Kein Versionssatz (analysiert als 1.0.0)].
- Fazit: Entfernen Sie phpdocumentor/Reflection-Docblock 3.1.1
- Installationsanforderung für Drush/Drush ^ 8.1 -> Erfüllbar durch Drush/Drush [8.1.0, 8.1.1, 8.1.10, 8.1.11, 8.1.12, 8.1.2, 8.1.3, 8.1.4, 8.1.5, 8.1.6, 8.1.7, 8.1.8, 8.1.9, 8.8.x-dev, 8.x-dev].
- Fazit: Installieren Sie phpdocumentor/Reflection-Docblock 3.1.1 nicht
- drush/drush 8.8.x-dev erfordert phpdocumentor/Reflection-Docblock ^ 2.0 -> erfüllt durch phpdocumentor/Reflection-Docblock [2.0.0, 2.0.0a1, 2.0.0a2, 2.0.0a3, 2.0. 1, 2.0.2, 2.0.3, 2.0.4, 2.0.5].
- Kann nur eines der folgenden Programme installieren: phpdocumentor/Reflection-Docblock [2.0.0, 3.1.1].
- Kann nur eines der folgenden Programme installieren: phpdocumentor/Reflection-Docblock [2.0.0a1, 3.1.1].
- Kann nur eines der folgenden Programme installieren: phpdocumentor/Reflection-Docblock [2.0.0a2, 3.1.1].
- Kann nur eines der folgenden Programme installieren: phpdocumentor/Reflection-Docblock [2.0.0a3, 3.1.1].
- Kann nur eines der folgenden Programme installieren: phpdocumentor/Reflection-Docblock [2.0.1, 3.1.1].
- Kann nur eines der folgenden Programme installieren: phpdocumentor/Reflection-Docblock [2.0.2, 3.1.1].
- Kann nur eines der folgenden Programme installieren: phpdocumentor/Reflection-Docblock [2.0.3, 3.1.1].
- Kann nur eines der folgenden Programme installieren: phpdocumentor/Reflection-Docblock [2.0.4, 3.1.1].
- Kann nur eines der folgenden Programme installieren: phpdocumentor/Reflection-Docblock [2.0.5, 3.1.1].
- Installationsanforderung für Phpdocumentor/Reflection-Docblock (gesperrt bei 3.1.1) -> Erfüllbar durch Phpdocumentor/Reflection-Docblock [3.1.1].

Die Installation ist fehlgeschlagen, und ./composer.json wird auf den ursprünglichen Inhalt zurückgesetzt.

2
spideringweb

Das Update war das Downgrade von phpdocumentor/Reflection-Docbloc auf 2.x mit composer require phpdocumentor/reflection-docblock:^2.0.

./composer.json wurde aktualisiert
Laden composer Repositorys mit Paketinformationen
Aktualisieren von Abhängigkeiten (einschließlich require-dev)
Paketvorgänge: 1 Installation, 1 Update, 0 Entfernungen
- Installieren von dflydev/markdown (v1.0.3): Herunterladen (100%)
Drupal\Core\Composer\Composer :: vendorTestCodeCleanup
- Aktualisierung von phpdocumentor/Reflection-Docblock (3.1.1 => 2.0.0): Herunterladen (100%)
Drupal\Core\Composer\Composer :: vendorTestCodeCleanup
Paket dflydev/markdown wird abgebrochen, Sie sollten es vermeiden. Verwenden Sie stattdessen michelf/php-markdown.
Sperrdatei schreiben
Autoload-Dateien generieren
Drupal\Core\Composer\Composer :: preAutoloadDump
Drupal\Core\Composer\Composer :: sureHtaccess

Installieren Sie dann Drush mit composer require drush/drush.

Verwenden von Version ^ 8.1 für Drush/Drush
./ composer.json wurde aktualisiert
Laden composer Repositorys mit Paketinformationen
Aktualisieren von Abhängigkeiten (einschließlich require-dev)
Paketvorgänge: 12 Installationen, 0 Updates, 0 Entfernungen

2
spideringweb

Hatte das gleiche Problem von D8.4beta1 gestartet.

Gelöst durch Umschalten auf Drush 9 mit:

composer require drush/drush:^9
3
Paul Paku

Ich konnte den Fehler mit den folgenden Befehlen reproduzieren:

composer create-project drupal/drupal 8 ^8.3
cd 8
composer update
composer require drush/drush

Der letzte Befehl ergab die folgende Ausgabe.

Verwenden von Version ^ 8.1 für Drush/Drush
./ composer.json wurde aktualisiert
Laden composer Repositorys mit Paketinformationen
Aktualisieren von Abhängigkeiten (einschließlich require-dev)
Ihre Anforderungen konnten nicht in einen installierbaren Satz von Paketen aufgelöst werden.

Problem 1
- drush/drush 8.1.0 kollidiert mit drupal/drupal [Keine Version festgelegt (analysiert als 1.0.0)].
- drush/drush 8.1.1 Konflikte mit drupal/drupal [Keine Version festgelegt (analysiert als 1.0.0)].
- drush/drush 8.1.2 Konflikte mit drupal/drupal [Keine Version festgelegt (analysiert als 1.0.0)].
- drush/drush 8.1.3 Konflikte mit drupal/drupal [Keine Version festgelegt (analysiert als 1.0.0)].
- drush/drush 8.1.4 Konflikte mit drupal/drupal [Keine Version festgelegt (analysiert als 1.0.0)].
- drush/drush 8.1.5 Konflikte mit drupal/drupal [Keine Version festgelegt (analysiert als 1.0.0)].
- drush/drush 8.1.6 Konflikte mit drupal/drupal [Keine Version festgelegt (analysiert als 1.0.0)].
- drush/drush 8.1.7 Konflikte mit drupal/drupal [Keine Version festgelegt (analysiert als 1.0.0)].
- drush/drush 8.1.8 Konflikte mit drupal/drupal [Keine Version festgelegt (analysiert als 1.0.0)].
- drush/drush 8.1.9 Konflikte mit drupal/drupal [Keine Version festgelegt (analysiert als 1.0.0)].
- Fazit: Drush/Drush 8.1.12 nicht installieren
- Fazit: Drush/Drush 8.1.11 nicht installieren
- Fazit: Drush/Drush 8.1.10 nicht installieren
- Fazit: Installieren Sie drush/drush 8.x-dev nicht
- Installationsanforderung für Drupal/Drupal Kein Versionssatz (analysiert als 1.0.0) -> Erfüllbar durch Drupal/Drupal [Kein Versionssatz (analysiert als 1.0.0)].
- Fazit: Entfernen Sie phpdocumentor/Reflection-Docblock 3.2.0
- Installationsanforderung für Drush/Drush ^ 8.1 -> Erfüllbar durch Drush/Drush [8.1.0, 8.1.1, 8.1.10, 8.1.11, 8.1.12, 8.1.2, 8.1.3, 8.1.4, 8.1.5, 8.1.6, 8.1.7, 8.1.8, 8.1.9, 8.8.x-dev, 8.x-dev].
- Fazit: Installieren Sie phpdocumentor/Reflection-Docblock 3.2.0 nicht
- drush/drush 8.8.x-dev erfordert phpdocumentor/Reflection-Docblock ^ 2.0 -> erfüllt durch phpdocumentor/Reflection-Docblock [2.0.0, 2.0.0a1, 2.0.0a2, 2.0.0a3, 2.0. 1, 2.0.2, 2.0.3, 2.0.4, 2.0.5].
- Kann nur eines der folgenden Programme installieren: phpdocumentor/Reflection-Docblock [2.0.0, 3.2.0].
- Kann nur eines der folgenden Programme installieren: phpdocumentor/Reflection-Docblock [2.0.0a1, 3.2.0].
- Kann nur eines der folgenden Programme installieren: phpdocumentor/Reflection-Docblock [2.0.0a2, 3.2.0].
- Kann nur eines der folgenden Programme installieren: phpdocumentor/Reflection-Docblock [2.0.0a3, 3.2.0].
- Kann nur eines der folgenden Programme installieren: phpdocumentor/Reflection-Docblock [2.0.1, 3.2.0].
- Kann nur eines der folgenden Programme installieren: phpdocumentor/Reflection-Docblock [2.0.2, 3.2.0].
- Kann nur eines der folgenden Programme installieren: phpdocumentor/Reflection-Docblock [2.0.3, 3.2.0].
- Kann nur eines der folgenden Programme installieren: phpdocumentor/Reflection-Docblock [2.0.4, 3.2.0].
- Kann nur eines der folgenden Programme installieren: phpdocumentor/Reflection-Docblock [2.0.5, 3.2.0].
- Installationsanforderung für Phpdocumentor/Reflection-Docblock (gesperrt bei 3.2.0) -> Erfüllbar durch Phpdocumentor/Reflection-Docblock [3.2.0].

Die Installation ist fehlgeschlagen, und ./composer.json wird auf den ursprünglichen Inhalt zurückgesetzt.

Eigentlich, composer update Folgendes ausgeben (unter anderem):

  • Aktualisieren von phpdocumentor/Reflection-Docblock (2.0.4 => 3.2.0): Herunterladen (100%)

Ich habe auch versucht, composer require drush/drush dev-master und/oder composer create-project drupal/drupal 8 8.4.*@dev aber alle Kombinationen verursachten die gleichen Fehlermeldungen.

Ich konnte Drush 8.1 mit Drupal 8.3) mit den folgenden Befehlen installieren.

composer create-project drupal/drupal 8 ^8.3
cd 8
composer require drush/drush
composer update

In diesem Fall installiert Composer nicht mehr phpdocumentor/Reflection-Docblock 3.2.0, sondern 2.0.5.

  • Aktualisieren von phpdocumentor/Reflection-Docblock (2.0.4 => 2.0.5): Herunterladen (100%)

drush status gibt Folgendes aus.

 Drupal version         :  8.3.5
 PHP executable         :  /usr/bin/php
 PHP configuration      :  /etc/php/7.1/cli/php.ini
 PHP OS                 :  Linux
 Drush script           :  /home/kiamlaluno/8/vendor/drush/drush/drush.php
 Drush version          :  8.1.12
 Drush temp directory   :  /tmp
 Drush configuration    :
 Drush alias files      :
 Drupal root            :  /home/kiamlaluno/8
 Drupal Settings File   :  MISSING
2
kiamlaluno

Hatte ein ähnliches Problem mit drush installiert twince sowohl auf/usr/lib/als auch auf der composer Webroot

0
augusto

Ich denke, der einfache Weg ist über

composer install
composer require drush/drush
0
Ankit Shah