it-swarm.com.de

Wie ändere ich die verwendete Version PHP)?

Ich verwende Drush, um Module zu aktualisieren. Wenn ich den Befehl php -v ausführe, wird korrekt angezeigt, dass ich Version 5.5 ausführe

Ich benutze dann den Befehl drush rf gefolgt von drush up, um Updates durchzuführen.

Ich verwende das Schema.org Metatag-Modul, für das PHP-Version 5 erforderlich ist. Auf der Website wird PHP-Version 5.5.37 ausgeführt

Die Standard-CLI-Version auf dem gemeinsam genutzten Hostgator-Server ist 5.4.45. Das habe ich ursprünglich für Drush verwendet. Als ich die folgende Nachricht erhielt, fand ich den Pfad zur Verwendung von PHP 5.5, aber ich erhalte immer noch die gleiche Nachricht. Ich kann also nicht herausfinden, wie PHP Version 5.4.45 noch angezeigt wird und wie dies behoben werden kann, damit dieses Modul nicht ständig deaktiviert wird.

Wenn Drush ein Update ausführt, wird folgende Meldung angezeigt: Schema.org Metatag erfordert mindestens PHP 5.5. (Derzeit wird PHP [Warnung] verwendet) 5.4.45)

Anschließend wird das Schema-Metatag-Modul deaktiviert.

HINWEIS: Wenn ich den Befehl drush ausführe: PHP Konfiguration: opt/php55/lib/php.ini Die Drush-Version ist 8.1.11

Vielen Dank

Zusatzinformation

.bash_profile

PATH=$PATH:$HOME/bin 
export PATH 
alias composer="/opt/php55/bin/php ~/bin/composer.phar" 
alias drush="/opt/php55/bin/php ~/.composer/vendor/bin/drush.php" 

.bashrc

 alias php='/opt/php55/bin/php' 
 alias composer='/opt/php55/bin/php ~/bin/composer'
 export DRUSH_PHP='/opt/php55/bin/php' 
  • php -v Gibt PHP 5.5.37
  • which php Gibt nichts zurück
  • drush status Gibt PHP configuration /opt/php55/lib/php.ini zurück

Wenn ich jedoch Drush zum Aktualisieren eines Moduls verwende, wird immer noch Folgendes angezeigt: Schema.org Metatag requires at least PHP 5.5. (Currently using PHP [warning] 5.4.45)

1
Jimmyk
  • Finden Sie den Pfad zur Binärdatei von PHP 5.5.
  • Finde den Weg zum Drush.

Execute

/path/to/php_55/bin/php /path/to/drush status
1
rovr138