it-swarm.com.de

Nvidia-Treiber funktionieren unter Kernel 4.15.0-33-generic nicht

Nach dem Aktualisieren des Systems und dem Neustart habe ich versucht, die NVIDIA X-Servereinstellungen zu starten, um festzustellen, ob mein Treiber ordnungsgemäß aktualisiert wurde. Es wurden keine Nvidia-Treiber installiert und Sudo lshw -c display ausgegeben

 *-display                 
   description: VGA compatible controller
   product: GP104 [GeForce GTX 1080]
   vendor: NVIDIA Corporation
   physical id: 0
   bus info: [email protected]:28:00.0
   version: a1
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
   configuration: driver=nouveau latency=0
   resources: irq:62 memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:c000(size=128) memory:f7000000-f707ffff

Ich habe nouveau in /etc/modprobe.d/blacklist.conf auf die schwarze Liste gesetzt:

blacklist nouveau
blacklist lbm-nouveau
alias nouveau off
alias lbm-nouveau off

und aktualisiert initramfs, aber lshw zeigte nach dem Neustart immer noch Nouveau. Ich habe auch versucht, xserver-xorg-video-nouveau zu deinstallieren, aber seltsamerweise hat dies nichts bewirkt. Ich habe auch Sudo ubuntu-drivers autoinstall ausgeführt, aber es wurde nichts installiert.

Ich konnte die proprietären Nvidia-Treiber nur durch Booten in Kernel 4.15.0-23-generic zum Laufen bringen. Ist es möglich, proprietäre Treiber dazu zu bringen, an -33 zu arbeiten?

BEARBEITEN: X11 scheint neu zu starten, wenn Sie Nouveau verwenden und bestimmte Anwendungen starten. Tilix, Firefox, Steam, Discord, Nautilus und System Monitor scheinen zu funktionieren, aber alle (getesteten) Einstellungsprogramme scheinen den Neustart zu verursachen. Wird nach dem Testen weiterer Apps aktualisiert

BEARBEITEN SIE 2: Weitere Tests zeigten, dass nur Settign-Anwendungen den Neustart zu verursachen scheinen. Dies umfasst Anzeigeeinstellungen, Systemeinstellungen, Budgie Desktop-Einstellungen, jedoch nicht NVIDIA X Server-Einstellungen. Ich sollte auch hinzufügen, dass der Neustart mich zurück zum Anmeldemenü und nicht zum Desktop bringt.

EDIT 3: Ich habe es behoben! Ich musste meinen Kernel mit Sudo apt install --reinstall linux-image-4.15.0-33-generic neu installieren und lshw zeigt den verwendeten Nvidia-Treiber an.

2
PixelPower

Ich habe es repariert! Ich musste meinen Kernel mit Sudo apt install --reinstall linux-image-4.15.0-33-generic neu installieren und lshw zeigt an, dass der Nvidia-Treiber verwendet wird.

1
PixelPower