it-swarm.com.de

Webex unter Ubuntu 16.04

Ich versuche, Webext zum Laufen zu bringen. Ich habe diese http://www.linuxintro.org/wiki/Use_WebEx_with_Linux gelesen, die mich auffordert, über ldd *.so | grep "not found" nach fehlenden Abhängigkeiten zu suchen.

Es gibt mir diese Liste:

~$ ldd .webex/1524/*.so | grep "not found"
    libgtk-x11-2.0.so.0 => not found
    libgdk-x11-2.0.so.0 => not found
    libXmu.so.6 => not found
    libXtst.so.6 => not found
    libstdc++.so.6 => not found
    libXt.so.6 => not found
    libXi.so.6 => not found
    libstdc++.so.6 => not found
    libstdc++.so.6 => not found
    libstdc++.so.6 => not found
    libjawt.so => not found
    libasound.so.2 => not found
    libstdc++.so.6 => not found
    libstdc++.so.6 => not found
    libjawt.so => not found
    libXmu.so.6 => not found
    libstdc++.so.6 => not found
    libstdc++.so.6 => not found
    libstdc++.so.6 => not found
    libuuid.so.1 => not found
    libstdc++.so.6 => not found
    libstdc++.so.6 => not found
    libstdc++.so.6 => not found
    libstdc++.so.6 => not found
    libstdc++.so.6 => not found

Wenn ich jedoch versuche, diese 'fehlenden' Abhängigkeiten zu installieren, wird mir mitgeteilt, dass sie bereits die neueste Version haben. Z.B.

~$ Sudo apt-get install libgtk2.0-0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libgtk2.0-0 is already the newest version (2.24.30-1ubuntu1).
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.

Also weiß ich nicht, wie ich das hinbekomme. Hat jemand Webex im Einsatz?

4

Ich denke, das Problem ist nicht das Fehlen von Abhängigkeiten in Linux, das Problem ist das WebEx-Update vor ein paar Wochen.

Ich habe in einem anderen Blog gelesen, dass das neue WebEx Java nicht mehr unterstützt, weshalb es bei uns nicht funktioniert.

2
user538798

Ich habe die Desktop Share Webex-Funktion auf dem neu installierten 16.04 folgendermaßen behoben: https://askubuntu.com/a/3634

aber ich habe 'openjdk-7-jre' durch 'openjdk - 8 - jre' und 'icedtea-7-plugin' durch 'icedtea - 8 - Plugin '

Das Webex-Verzeichnis enthält immer noch Dateien, die nicht gefunden wurden, und Audioanrufe funktionieren immer noch nicht, aber ich benötige sie nicht (wir verwenden Skype).

5
Yuri Gor

Ich konnte es ziemlich gut zum Laufen bringen, dank Yuris Antwort und einigen der anderen hier. Ich dachte, ich könnte einige zusätzliche Details und explizite Schritte angeben.

Zunächst starte ich das JDK 8 von Oracle, das über PPA auf einer 64-Bit-Plattform installiert wurde. Auf diese Weise wird das Besprechungs-Dashboard gestartet, die Desktopfreigabe funktioniert jedoch nicht, da WebEx eine 32-Bit-Grundlage verwendet. Also habe ich die 32-Bit-Architektur hinzugefügt:

Sudo dpkg --add-architecture i386
Sudo apt update

Dann habe ich die 32-Bit-Pakete installiert:

Sudo apt install openjdk-8-jre:i386 libxmu6:i386 libpangoxft-1.0-0:i386 libpangox-1.0-0:i386 libxv1:i386

Dies zieht eine ganze Reihe von Abhängigkeiten nach sich. Nach der Installation der Pakete zeigen die WebEx-Bibliotheken alle erfüllten Abhängigkeiten an (mit Ausnahme von libjawt.so, das von der JRE bereitgestellt wird):

$ ldd ~/.webex/T30_MC/*.so | grep "not found"
        libjawt.so => not found
        libjawt.so => not found

Starten Sie Firefox neu (ich bin nicht sicher, ob dies unbedingt erforderlich ist, aber ich wollte sichergehen, dass alle neuen Bibliotheken vorhanden sind). Danach konnte ich an meiner Besprechung teilnehmen und den freigegebenen Desktop anzeigen. Ich habe Audio noch nicht ausprobiert, da für das Meeting, an dem ich teilgenommen habe, Web-Audio nicht aktiviert war.

4
Mac

Ich habe diesen Ansatz gewählt, indem ich

Sudo dpkg --add-architecture i386
Sudo apt-get update
Sudo apt-get upgrade

und Firefox neu gestartet.

0
user_rj

Ich habe versucht, Folgendes hinzuzufügen:

OPTION 1

Sudo apt-get -y remove icedtea-7-plugin:i386 icedtea-netx:i386
Sudo apt-get -y install openjdk-8-jre:i386 libxmu6:i386 icedtea-8-plugin firefox
Sudo update-alternatives --set mozilla-javaplugin.so /usr/lib/jvm/Java-8-openjdk-AMD64/jre/lib/AMD64/IcedTeaPlugin.so

OPTION 2

Sudo dpkg --add-architecture i386
Sudo apt-get update
Sudo apt-get upgrade

Und jetzt kann ich den WebEx ganz gut öffnen, aber ich kann die Audio-Option nicht verwenden und ich kann nicht sehen, was andere teilen. Weiß jemand, ob dies in Ubuntu 16.04 behoben werden kann?

0
user538798
apt-get install openjdk-8-jre:i386

Der obige Befehl sollte den größten Teil des Problems beheben, wenn nicht alles. Ich habe auch das Folgende getan, um es zu beenden.

apt-get install libuuid1:i386 libasound2:i386 libxt6:i386 libxmu6:i386
0
Patrick