it-swarm.com.de

Installieren Sie Firefox Quantum in Debian 9 Stretch

Ich suche, wo ich den neuen Browser Firefox Quantum installieren und ausprobieren kann. Ich habe nicht gefunden, wie ich ihn bekommen kann. Kann mir bitte jemand sagen, welche Repositories oder Links ich herunterladen und installieren soll?

Vielen Dank.

11
Spartan

Fügen Sie deb http://ftp.hr.debian.org/debian sid main contrib non-free Zu /etc/apt/sources.list Hinzu und installieren Sie es mit diesem Befehl:

apt install -t sid firefox

Dadurch wird nur Firefox von instabil installiert. Der Rest der Pakete bleibt auf stretch.


Hinzugefügt von cas 2018-04-19 (weil es durchaus üblich ist, dass Leute etwas von instabil installieren möchten, ohne alles auf instabil zu aktualisieren, und die Antwort hier gilt nicht nur für Firefox):

Dies ist eine gute Antwort, aber unvollständig. Es gibt zwei weitere Dinge, die erledigt werden müssen , bevor apt install -t sid firefox Ausgeführt wird.

  1. Fügen Sie APT::Default-Release "stable"; Zu /etc/apt/apt.conf Oder einer Datei in /etc/apt/apt.conf.d/ Hinzu, sodass apt nur Pakete von installiert sid/unstable, wenn Sie es explizit mit -t sid mitteilen.

    Wenn Sie die Standardversion nicht auf stabil setzen, wird beim nächsten Upgrade oder dist-Upgrade Ihr gesamtes System auf sid aktualisiert. Die meisten Leute wollen das nicht.

    Wenn Sie eine benannte Debian-Distribution wie jessie oder stretch in Ihrer sources.list - Datei verwenden, verwenden Sie diesen Namen anstelle des generischen stable.

  2. führen Sie apt update aus, um die lokale Paketdatenbank zu aktualisieren.

Schließlich installiert apt install -t sid firefox Nicht nur das Paket firefox, sondern auch den Mindestsatz an aktualisierten und neuen Paketen, die erforderlich sind, um die Abhängigkeiten des neuen Firefox-Pakets zu erfüllen. Dies sind normalerweise nur einige Firefox-bezogene Pakete, die aus derselben Quelle erstellt wurden, können aber auch andere Pakete enthalten - z. ob das neue Firefox von einer neueren Version eines Bibliothekspakets abhängt.

Manchmal kann es sogar dazu führen, dass ein wichtiges Paket wie libc6 Aktualisiert wird, was dann eine riesige Kaskade anderer Paket-Upgrades auslöst und Sie effektiv auf einen Hybrid aus stabil und instabil aktualisiert. Dies ist im Allgemeinen schlimmer als ein vollständiges Dist-Upgrade auf instabil. In diesem Fall haben Sie zwei gute Möglichkeiten: 1. Brechen Sie das Firefox-Upgrade ab und warten Sie, bis es in Stable oder https://backports.debian.org) eintrifft / ; 2. Abbrechen und Upgrade auf instabil (was nicht so schlimm ist, wie es sich anhört. In Debian bedeutet "instabil" nicht "stürzt ständig ab". Es bedeutet "Vorabversion, ändert sich ständig. Manchmal können Dinge kaputt gehen und erfordern manuelle Befestigung ")

8

https://blog.mozilla.org/blog/2017/09/26/firefox-quantum-beta-developer-edition/

Wenn Sie bereits zu den Firefox-Gläubigen gehören, werden Sie am 14. November automatisch auf Firefox Quantum upgraden. Wenn Sie jedoch die neuesten Erkenntnisse genießen, können Sie sie in der Beta auf Desktop, Android und iOS ausprobieren. Wenn Sie ein Webentwickler sind, laden Sie die Developer Edition herunter, die brandneue, hochmoderne Tools für diejenigen enthält, die das Web erstellen.

sie könnten einfach ein paar Wochen warten. oder Sie können das beta herunterladen, das im tar.gz-Format vorliegt

quantum scheint also kein "brandneues Firefox" zu sein, sondern ein Update.

hey, wenn es wirklich nur um die Installation einer Beta-Version geht, können Sie einfach das Firefox-Beta-Repo hinzufügen: https://launchpad.net/~mozillateam/+archive/ubuntu/firefox-next

3
JPT

BEARBEITEN: Es ist jetzt instabil, daher wurde der Link in https://packages.debian.org/sid/firefox geändert

ALTE ANTWORT: Firefox Quantum ist in Debian Experimental verfügbar ( https://packages.debian.org/experimental/firefox ). Sie können die Deb-Datei wahrscheinlich einfach von dort herunterladen und installieren.

3
JBBgameich

Firefox Quantum (Mozilla 57.0) ist ab sofort auf der offiziellen Website verfügbar. Sie können es von hier herunterladen.

wget https://download-installer.cdn.mozilla.net/pub/firefox/releases/57.0/linux-x86_64/en-US/firefox-57.0.tar.bz2
tar xvf firefox-57.0.tar.bz2
Sudo unlink /usr/bin/firefox
Sudo ln -s ~/firefox-57.0/firefox /usr/bin/firefox
firefox
2
GAD3R

Ich war nur mehr oder weniger gezwungen, dies zu tun, weil Amazon Prime Video (zumindest die indische Version) entschied, dass es mit dem Firefox im Stall nicht mehr funktionieren würde. Damit wäre Chrome als einziger installierter Hauptbrowser in der Lage, Amazon Video auszuführen.

Da 57 in instabil verfügbar ist, bestand die Möglichkeit darin, zu versuchen, es zurück zu portieren oder es einfach direkt zu installieren, und zu hoffen, dass es nicht viele Dinge aus instabil herausholt. Zum Glück, wie Sie unten sehen können, war dies nicht der Fall. Ich denke, ein richtiger Backport wäre immer noch besser, aber es wäre viel mehr Aufwand.

Insbesondere wurden die folgenden Pakete von instabil installiert:

fontconfig-config libevent-2.1-6 libfontconfig1 libfontconfig1:i386 libfontconfig1-dev libhunspell-1.6-0 libnss3 libnss3-dev

Ein konservativerer Ansatz wäre, zu versuchen, apt zu zwingen, nur Pakete aus Stable zu verwenden

apt-get install firefox/unstable

es ist jedoch auch etwas wahrscheinlicher (im Allgemeinen), dass dieser Ansatz Probleme verursacht, da dies nicht die Version ist, mit der dieses Firefox-Paket normalerweise arbeiten würde.

Bitte beachten Sie, dass die Installation von Paketen von instabil im Allgemeinen keine gute Idee ist.

Soweit ich das beurteilen kann, scheint nichts Schlimmes passiert zu sein.

[email protected]:/home/faheem# apt-get install -t unstable firefox
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  fontconfig-config libevent-2.1-6 libfontconfig1 libfontconfig1:i386 libfontconfig1-dev libhunspell-1.6-0 libnss3 libnss3-dev
Suggested packages:
  mozplugger
The following NEW packages will be installed:
  firefox libevent-2.1-6 libhunspell-1.6-0
The following packages will be upgraded:
  fontconfig-config libfontconfig1 libfontconfig1:i386 libfontconfig1-dev libnss3 libnss3-dev
6 upgraded, 3 newly installed, 0 to remove and 3423 not upgraded.
Need to get 44.8 MB of archives.
After this operation, 160 MB of additional disk space will be used.
Do you want to continue? [Y/n] 

Beachten Sie auch, dass Sie den stabilen Firefox (Version 52) und den neuen Firefox von unstable (57) nebeneinander installieren.

[email protected]:/home/faheem# dpkg -l | grep firefox
ii  firefox                             57.0.4-1               AMD64                  Mozilla Firefox web browser
ii  firefox-esr                         52.5.2esr-1~deb9u1     AMD64                  Mozilla Firefox web browser - Extended Support Release (ESR)

Und es sieht so aus, als hätten die Firefox-Betreuer weit genug vorausgedacht, um Umleitungen für die ausführbare Datei firefox zu ermöglichen.

[email protected]:/home/faheem# dpkg -S /usr/bin/firefox
diversion by firefox-esr from: /usr/bin/firefox
diversion by firefox-esr to: /usr/bin/firefox.real
firefox, firefox-esr: /usr/bin/firefox
2
Faheem Mitha

Obwohl dies eine alte Frage ist, denke ich, dass snap zumindest erwähnt werden sollte. Es ist meiner Meinung nach viel bequemer als die Installation von Sid.

Snap installieren:

Sudo apt install snapd

Installieren Sie Firefox:

Sudo snap install firefox

1
iuvbio

Ich bin mir nicht sicher, warum die Antwort von @ stanislav-vlasic abgelehnt wurde. Ich gehe davon aus, dass er einen bestimmten Spiegel vorschlägt. Hier ist ein Tipp, wie Sie für Ihren aktuellen Debian-Spiegel Sid werden können:

egrep '^deb .*? stretch ' /etc/apt/sources.list \
    | head -n1 \
    | sed 's/stretch/sid/g' \
    | Sudo tee --append /etc/apt/sources.list

Sudo apt update
Sudo apt install -t sid firefox

Das scheint mir zum Zeitpunkt des Schreibens ein Firefox-Quantum beschert zu haben, keine Versprechen auf Stabilität!

Ah, ich verstehe jetzt, passendes Pinning ist weniger als trivial. Ich habe eine viel präzisere Option gefunden, die veröffentlicht wurde von: https://linuxconfig.org/how-to-install-firefox-quantum-on-debian-stretch- Linux

Was im Detail sowohl die deb <your mirror> sid main Repository-Zeile in /etc/apt/sources.list sowie das Anheften von apt.

Ich werde folgende Empfehlung aussprechen:

# /etc/apt/preferences.d/sid
Package: *
Pin: release a=unstable
Pin-Priority: -1

Installieren Sie ein neues Firefox:

Sudo apt install firefox -t sid

Machen Sie den neuen Firefox zum Standard

Sudo apt remove firefox-esr
0
ThorSummoner

Das folgende Skript lädt die neueste Version von Firefox herunter (entweder vom Stable- oder vom Beta-Kanal) und packt sie zur Installation in eine .deb-Datei.

Laden Sie die unten verlinkte Zip-Datei herunter, extrahieren Sie sie und führen Sie ./build-firefox.sh vom Terminal.

Präzisiere das --install Flag beim Ausführen des Skripts, um es nach dem Erstellen automatisch zu installieren.

https://github.com/skmkenn/linuxscripts-build-firefox/archive/master.Zip

0
user255641