it-swarm.com.de

Debian: Das Repository hat keine Release-Datei

Wenn ich versuche, einige Programme von der Quelle zu installieren oder speziell ein apt-Update auszuführen, erhalte ich folgende Meldung:

E: The repository 'http://ftp.ca.debian.org/debian stretch/updates Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Ich fing an, dies zu bekommen, nachdem ich die Architektur i386 hinzugefügt hatte. Ohne sie wäre ich nicht in der Lage, den proprietären Nvidia-Treiber zu installieren, und der Steam-Client würde überhaupt nicht starten. Das ist was mein /etc/apt/sources.list liest:

deb http://ftp.ca.debian.org/debian/ stretch main contrib non-free
deb-src http://ftp.ca.debian.org/debian/ stretch main contrib non-free

deb http://ftp.ca.debian.org/debian/ stretch/updates main contrib non-free
deb-src http://ftp.ca.debian.org/debian/ stretch/updates main contrib non-free

####stretch-updates, previously known as 'volatile'

deb http://ftp.ca.debian.org/debian/ stretch-updates main contrib non-free

deb-src http://ftp.ca.debian.org/debian/ stretch-updates main contrib non-free
42
user77647

Du hast beide stretch-updates und stretch/updates, aber letzteres existiert nicht mehr (zumindest auf dem Spiegel, den Sie verwenden). Sie sollten die Verweise auf stretch/updates oder - wenn Sie das stretch/updates Zeilen zur Bereitstellung von Sicherheitsupdates - ersetzen Sie diese durch

deb http://security.debian.org/ stretch/updates main contrib non-free
27
Stephen Kitt