it-swarm.com.de

Aktualisieren von WordPress und Plugins; irgendwelche Tipps, um Probleme zu vermeiden?

Werden Sie WordPress 2.7.1 mit allen Plugins auf 3.0.1 upgraden? Gibt es Tipps, die Sie ohne Probleme ausführen können?

Bearbeiten: 7. September

Das Dashboard zeigt "Neue Version verfügbar" sowohl für die WordPress-Version als auch für einige Plugins.

Also möchte ich alles upgraden. Was sollte dann zuerst aktualisiert werden, WordPress oder Plugins?

Und welches Update eignet sich am besten für die automatische Aktualisierung über das Dashboard oder die manuelle Aktualisierung über FTP

5

Sie sollten keine Probleme haben ... aber bevor Sie das Upgrade durchführen, empfehle ich Ihnen Folgendes:

Alles sichern

  1. Sichern Sie Ihr Thema
  2. Sichern Sie alle Ihre Plug-Ins
  3. Sichern Sie Ihre vorhandene Datenbank

Auf diese Weise können Sie das Upgrade bei Bedarf "rückgängig machen".

Überprüfen Sie die Theme-Kompatibilität

Wenn Sie ein allgemein verfügbares Thema verwenden, stellen Sie vor dem Upgrade sicher, dass es mit WordPress 3.0.1 kompatibel ist. Die Chancen stehen gut, aber wenn Sie dies vor dem Upgrade noch einmal überprüfen können, können Sie sich potenzielle Kopfschmerzen ersparen. Ich habe gesehen, wie Leute versucht haben, ein Upgrade von Version 2.0 auf Version 2.9 mit Themen durchzuführen, die danach kaputt gingen ...

Überprüfen Sie die Plug-In-Kompatibilität

Einige Plug-Ins funktionieren möglicherweise nicht mit der neuen Version von WordPress. Überprüfen Sie vor dem Upgrade, ob sie als kompatibel eingestuft sind. Wenn dies nicht der Fall ist, stellen Sie sich auf ein Plug-In ein, das möglicherweise nicht funktioniert. Wenn dies unbedingt erforderlich ist, suchen Sie nach einer möglichen Alternative, falls dies nicht der Fall ist. ' nicht funktionieren.

Ich habe verschiedene Kalender-Plug-Ins in einer neuen Version von WordPress versagen lassen. Stellen Sie also sicher, dass Sie eine Option zur Verfügung haben, falls etwas schief geht.

Seien Sie trotzdem darauf vorbereitet, dass alles funktioniert

Ich habe in den letzten Wochen mehrere Systeme problemlos von 2.7.X auf 3.0 aktualisiert. Es besteht also eine sehr gute Chance , dass Ihr Update problemlos durchgeführt wird, und diese Vorsichtsmaßnahmen waren Zeitverschwendung. Aber es ist besser, die Zeit jetzt zu verschwenden, als nach dem Upgrade eine kaputte Site reparieren zu müssen.

Letzter Vorschlag

Aktualisieren Sie Ihre Plug-Ins nacheinander. Wenn Sie eine ganze Reihe von Dingen auf einmal aktualisieren, kann es schwieriger sein, die Fehlerursachen zu ermitteln (falls welche auftreten). Indem Sie die Plug-Ins einzeln aktualisieren, können Sie Probleme eingrenzen und beheben. Wenn ein Plug-in nach dem Upgrade nicht funktioniert, können Sie jederzeit zu dem zuvor erstellten Backup zurückkehren.

3
EAMann

Die eine Sache, die ich zu EAManns Antwort hinzufügen möchte, ist, dass Sie möglicherweise eine Testversion der Site einrichten möchten, damit Sie ein Schein-Upgrade ohne Konsequenzen durchführen können. Wenn es dann Probleme gibt, kennen Sie diese, bevor Sie Änderungen vornehmen, und wissen (hoffentlich), wie Sie sie ebenfalls beheben können. Dies ist jedoch kein Ersatz für häufiges und korrektes Sichern.

3
John P Bloch