it-swarm.com.de

Ich kann für meine benutzerdefinierte Taxonomie nicht auf die Seiten zugreifen

Ich arbeite an einer Rezeptwebsite mit einem benutzerdefinierten Beitragstyp, Rezepten, mit zwei benutzerdefinierten Taxonomien für die Behandlung von Rezeptkategorien und Tags. Der benutzerdefinierte Beitragstyp funktioniert ebenso wie die benutzerdefinierte Taxonomie für die Kategorien, d. H. Ich kann auf einzelne Beiträge und Kategorieseiten zugreifen. Wenn ich jedoch versuche, auf eine benutzerdefinierte Taxonomie-Tag-Seite zuzugreifen, erhalte ich die WordPress 404-Seite.

Ich weiß nicht wirklich, wie ich das beheben soll, da WordPress mir keine nützlichen Fehlercodes gibt. Irgendwelche Vorschläge?

2
AginaDendata

Ich bin auch auf dieses Problem gestoßen, zweimal, zwei verschiedene Fehler, das erste Mal, als ich in den WordPress-Optionen zur Permalink-Struktur ging und auf Speichern drückte, war dies ein Problem mit meinen HTAccess-Dateien, und das zweite Mal war es so, wie ich es tat registriere die Schnecke,

Hier ist ein vollständiges Beispiel:

/* Post type : offre_emploi */
register_post_type(
    "offre_emploi", /*Take this in note you'll need it*/
    ...

/* Register Taxonomy */
$labelsEmploisCat = array(
    'name' => _x( 'Catégories', 'post type general name' ),
    'singular_name' => _x( 'Catégorie', 'post type singular name' ),
    'add_new' => _x( 'Ajouter une catégorie', 'client' ),
    'add_new_item' => __( 'Ajouter une catégorie' ),
    'edit_item' => __( 'Modifier une catégorie' ),
    'new_item' => __( 'Modifier une catégorie' ),
    'view_item' => __( 'Voir une catégorie' ),
    'search_items' => __( 'Rechercher une catégorie' ),
    'not_found' =>  __( 'Aucune catégorie' ),
    'not_found_in_trash' => __( 'Aucune catégorie' ),
    'parent_item_colon' => ''
);

register_taxonomy(
    "proprietaires_pieces",
    array("offre_emploi"), //here goes the post type 
    array(
        "hierarchical" => true,
        "labels" => $labelsEmploisCat,
        "rewrite" => true
    )
);

Hoffe es hilft dir

1

Ich habe mit 404s in Bezug auf benutzerdefinierte Post-Typen/Taxonomien seltsame Probleme. Versuchen Sie erneut, auf der Einstellungsseite für Blog-Permalinks auf Speichern zu klicken. Seltsam, wie es klingt, das meine Probleme geklärt hat.

0
Dave Konopka