it-swarm.com.de

CUDA 7.5-Installation: Nicht unterstützter Compiler-Fehler

Ich habe gerade versucht, CUDA 7.5 auf meinem Laptop zu installieren. Ich habe lightdm deaktiviert und Sudo sh cuda7.5.run. Die Treiberinstallation wurde bestanden, aber dann wurde ein Fehler Unsupported compiler ... angezeigt, und die Installation schlägt fehl. Wie kann ich dieses Problem beheben?

5
Amir

Das Problem war mit Ubuntu 15.10. Ich habe 14.04 installiert und konnte CUDA installieren. Für meinen Laptop gab es jedoch einen subtilen Punkt zu erwähnen. Ich musste den NVIDIA-Treiber über System Settings --> Software & Updates --> Additional Drivers installieren und den tested-Treiber auswählen. Dann habe ich CUDA installiert und No auf die Treiberinstallation mit der CUDA-Installationsdatei geantwortet.

1
Amir

Ich hatte ein ähnliches Problem bei der Installation von CUDA 7.5 in Ubuntu 16.04.

Ich habe es mit gcc/g ++ 4.8 anstelle von 5.2 gelöst.

Sie können es installieren und die Standardversion mit dem Befehl update-alternatives --install wechseln

Für gcc 4.8:

Sudo apt-get install gcc-4.8
Sudo update-alternatives --remove-all gcc
Sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.8 10

Für g ++ 4.8:

Sudo apt-get install g++-4.8
Sudo update-alternatives --remove-all g++
Sudo update-alternatives --install /usr/bin/g++ g++ /usr/bin/g++-4.8 10
23

Sie müssen Ihre gcc-Version nicht downgraden. Für die Personen, die ihre gcc-Version beibehalten möchten, empfehle ich die folgende Methode. http://kislayabhi.github.io/Installing_CUDA_with_Ubuntu/

1
Dave.Cheng

Sudo apt-get update unity sollte auch helfen

0
Kartik Sonu