it-swarm.com.de

Wie installiere ich Termite

Ich benutze Openbox auf UbuntuGnome .. wenn das hilft.

Also habe ich die Dokumentation hier durchgesehen:

https://wiki.archlinux.org/index.php/Termite

und ich kann nicht herausfinden, wie man es installiert. Ich bin sehr unerfahren und möchte nur eine einfache Erklärung, oder zumindest einen Stups in die richtige Richtung.

Ich habe auch die Anweisungen hier befolgt: https://github.com/thestinger/termite

Hat folgendes gemacht:

git clone --recursive https://github.com/thestinger/termite.git
cd termite && make

dann hol dir das:

ask @ ubuntu: ~/termite $ make 
 Das Paket gtk + -3.0 wurde nicht im Suchpfad von pkg-config gefunden. 
 Vielleicht sollten Sie das Verzeichnis mit `gtk + -3.0.pc '[hinzufügen. ____.] zur Umgebungsvariablen PKG_CONFIG_PATH 
 Kein Paket 'gtk + -3.0' gefunden 
 Paket vte-2.91 wurde nicht im Suchpfad pkg-config gefunden. 
 Vielleicht sollten Sie hinzufügen Das Verzeichnis mit 'vte-2.91.pc' 
 für die Umgebungsvariable PKG_CONFIG_PATH 
 Kein Paket 'vte-2.91' gefunden 
 Das Paket gtk + -3.0 wurde in der pkg-config nicht gefunden Suchpfad. 
 Vielleicht sollten Sie das Verzeichnis mit `gtk + -3.0.pc '
 der Umgebungsvariablen PKG_CONFIG_PATH 
 hinzufügen. Kein Paket' gtk + -3.0 'gefunden 
 Das Paket vte-2.91 wurde nicht im Suchpfad pkg-config gefunden. 
 Vielleicht sollten Sie das Verzeichnis mit `vte-2.91.pc '
 Zur Umgebungsvariablen PKG_CONFIG_PATH 
 Nr. Hinzufügen Paket 'vte-2.91' gefunden 
 g ++ -std = c ++ 11 -O3 -Wand -Wextra -pedantic -Winit-self -Wshadow -Wform at = 2 -Wmissing-Declarations -Wstrict-overflow = 5 -Wcast-align -Wconversion -Wunused-Makros -Wwrite-Strings -DNDEBUG -D_POSIX_C_SOURCE = 200809L -DTERMITE_VERSION =\"v11 \" -Wno-missing-field-initializers - s -Wl, - nach Bedarf termite.cc -o termite 
 termite.cc:31:21: Schwerwiegender Fehler: gtk/gtk.h: Keine solche Datei oder Verzeichnis 
 wurde beendet. 
 Makefile: 36: Rezept für Ziel 'Termite' fehlgeschlagen 
 Make: *** [Termite] Error 1
14
Pepe

Over hier ist ein Installationsskript, das alle Abhängigkeiten und Sachen gut erklärt. Ich kopiere das einfach für dich;)

Abhängigkeiten installieren

Sudo apt install -y g++ libgtk-3-dev gtk-doc-tools gnutls-bin \
    valac intltool libpcre2-dev libglib3.0-cil-dev libgnutls28-dev \
    libgirepository1.0-dev libxml2-utils gperf build-essential

Hole und installiere vte-ng

git clone https://github.com/thestinger/vte-ng.git
echo export LIBRARY_PATH="/usr/include/gtk-3.0:$LIBRARY_PATH"
cd vte-ng && ./autogen.sh && make && Sudo make install
cd ..

Termite holen und installieren und einrichten

git clone --recursive https://github.com/thestinger/termite.git
cd termite && make && Sudo make install
Sudo ldconfig
Sudo mkdir -p /lib/terminfo/x
Sudo ln -s /usr/local/share/terminfo/x/xterm-termite /lib/terminfo/x/xterm-termite

Voila, das sollte es sein ....

12
db429

Sie können termite unter Ubuntu mit folgendem Skript installieren:

Termite Installer

0
Ali Zeynali

Ich denke, der einfachste Weg, um zu installieren, ist der folgende:

cd /tmp
wget https://raw.githubusercontent.com/Corwind/termite-install/master/termite-install.sh
chmod +x ./termite-install.sh
./termite-install.sh

Aktualisieren Sie jetzt Ihren Standard-Terminalemulator:

Sudo update-alternatives --config x-terminal-emulator

Haben Sie einen guten Tag!

0
blkpws

Eine praktikable Alternative wäre die Installation von Terminator , das für alle derzeit unterstützten Versionen von Ubunt verfügbar ist

Dies ist ein sehr einfacher Prozess in zwei Schritten.

1) niversums-Repository aktivieren

2) installiere terminator entweder über das Ubuntu Software Center oder über die Kommandozeile in einem Terminal mit dem Kommando Sudo apt-get install terminator

Dies könnte eine bessere Wahl sein, da einige sagen, dass der Terminator überlegen ist, da er das Terminalfenster in mehrere Bereiche aufteilen kann und Sie die Größe nach Bedarf ändern können. Es werden auch mehrere Fenster und Registerkarten unterstützt.

Quellen:

Erfahrung

https://www.slant.co/versus/2444/2462/~terminator_vs_termite

0
Elder Geek

Anscheinend haben Sie die erforderlichen DEPENDENCIES nicht installiert. Es könnte das Problem sein

Das Paket vte-2.91 wurde nicht im Suchpfad pkg-config gefunden. Versuchen Sie, vte-ng https://github.com/thestinger/vte-ng zu installieren

0
Mohit Rajan