it-swarm.com.de

SSL / TLS-Fehler bei Links und Luchs - möglicherweise aufgrund von CloudFlare

Ich arbeite oft im Terminal - zum Beispiel auf einem von mir eingerichteten VPS -, auch zum Surfen mit links und lynx. Leider habe ich einige Fehler bekommen:

links:

 Fehler beim Laden von https://www.thepiratebay.se/: 
 SSL-Fehler 

luchs:

 Zuerst www.thepiratebay.se nachschlagen 
 Zuerst www.thepiratebay.se nachschlagen 
 HTTP-Verbindung zu www.thepiratebay.se herstellen 
 HTTP-Anfrage senden 
 HTTP-Anfrage gesendet; Warten auf Antwort. 
 HTTP/1.1 301 Permanent verschoben 
 'Immer zulassen von Domain' .thepiratebay.se '. 
 Datenübertragung abgeschlossen 
 HTTP/1.1 301 Permanent umgezogen 
 Verwenden von https://www.thepiratebay.se/[.____.‹ Nachschlagen von www.thepiratebay.se 
 Herstellen einer HTTPS-Verbindung zu www.thepiratebay.se 
 Erneuter Verbindungsaufbau ohne TLS. 
 Nachschlagen von www.thepiratebay.se 
 Herstellen einer HTTPS-Verbindung zu www.thepiratebay.se 
 Warnung !: Es kann keine sichere Verbindung zum Remote-Host hergestellt werden. 
 
 Luchs: Kein Zugriff auf Startdatei http://www.thepiratebay.se/

Haftungsausschluss: ThePirateBay ist natürlich nur ein Beispiel - aus vollständig herausgenommen die Luft ... und außerdem , wenn ich die Site tatsächlich benutzte, wäre es nur, alle ausführlichen Artikel zu lesen ...

Ich bin auf dasselbe Problem auch bei einigen anderen Websites gestoßen, und ich vermute, dass es etwas mit CloudFlare zu tun haben könnte (ich bin mir jedoch nicht sicher) ...

firefox und chrome haben keine SSL/TLS-Probleme mit denselben Sites.

Ich verwende ein aktuelles Ubuntu 14.04.4 x64 auf DigitalOcean.

Bearbeiten: Versionen:

Luchs:

 Lynx Version 2.8.8pre.4 (04.02.2014) 
 Libwww-FM 2.14, SSL-MM 1.4.1, GNUTLS 2.12.23, ncurses 5.9.20140118 (wide) 
 Errichtet auf Linux-Gnu 5. Februar 2014 17:12:49 

Links:

Links 2.8

4
Baard Kopperud

Erster Luchs:
Laut Bericht von SSLLabs unterstützt der Server nur ECDHE-Verschlüsselungen. Basierend auf einer Paketerfassung bei Verwendung von lynx in 14.04 bietet es keine ECDHE-Chiffren. Dies bedeutet, dass sich die Chiffren nicht überschneiden und der Handshake fehlschlägt.

Und Links:
Laut SSLLabs-Bericht benötigt die Site einen Client mit Unterstützung für SNI . Links haben SNI-Unterstützung mit Version 2.10, aber Sie verwenden nur 2.8. Daher wird der Handshake fehlschlagen.

3
Steffen Ullrich