it-swarm.com.de

Schwierigkeiten beim Mounten einer ISO-Datei "mount: Sie müssen den Dateisystemtyp angeben"

Ich habe eine .iso-Datei, die ich mounten möchte. Ich habe einen Ordner in/mnt/iso als Einhängepunkt erstellt. Jetzt versuche ich:

Sudo mount -o loop filename.iso /mnt/iso

und die antwort ist:

mount: you must specify the filesystem type

und der Ordner von/mnt/iso ist leer. Ich habe versucht mit

Sudo mount -o loop -t ext4 filename.iso /mnt/iso

darin steht, dass mount: falscher fs-Typ, falsche Option, falscher Superblock auf/dev/loop0, fehlende Codepage oder fehlendes Hilfsprogramm oder ein anderer Fehler (und mehr Text) ...

Ich fand den Dateisystemtyp mit df -T und mount in der Befehlszeile.

Was könnte fehlen oder falsch sein?

3
Vass

Der Dateityp, den Sie zum Mounten einer ISO-formatierten Datei benötigen, ist iso966. Hier ist ein Beispiel:

Ein gutes .iso:

[email protected]:~(0)$ file  /usr/lib/memtest86+/memtest86+.iso  
/usr/lib/memtest86+/memtest86+.iso: # ISO 9660 CD-ROM filesystem data  MT410 ' (bootable)  `

Ein Verzeichnis, in das es geladen werden soll: `

[email protected]:~(0)$ ls -ld ~/tmp/mp  
drwxrwxr-x 2 walt walt 4096 2012-01-01 13:55 /home/walt/tmp/mp`  

Die eigentliche Montierung:

[email protected]:~(1)$ Sudo mount -t iso9660 /usr/lib/memtest86+/memtest86+.iso /home/walt/tmp/mp    
mount: warning: /home/walt/tmp/mp seems to be mounted read-only.`  

Und hier ist es!

[email protected]:~(0)$ ls !$  
ls /home/walt/tmp/mp  
boot  readme.txt  
[email protected]:~(0)$  df -H /home/walt/tmp/mp  
Filesystem             Size   Used  Avail Use% Mounted on  
/dev/loop0             1.9M   1.9M      0 100% /home/walt/tmp/mp  
[email protected]:~(0)$   
6
waltinator