it-swarm.com.de

Lösen von Multilib-Versionsproblemen

Ich benutze Centos 6.4

Als ich versuchte, libgcc mit yum install libgcc.i686 Zu installieren, nahm ich folgende Massagen.

Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:

         1. You have an upgrade for libgcc which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of libgcc of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude libgcc.otherarch ... this should give you an error
            message showing the root cause of the problem.

         2. You have multiple architectures of libgcc installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.

         3. You have duplicate versions of libgcc installed already.
            You can use "yum check" to get yum show these errors.

       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).

       Protected multilib versions: libgcc-4.4.7-4.el6.i686 != libgcc-4.4.7-3.el6.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles –nodigest

Wie kann ich libgcc.i686 installieren?

19
user1345414

Es scheint dein libgcc.x86_64 hat eine andere Version als das libgcc.i686 Sie versuchen zu installieren (4.4.7-3 vs. 4.4.7-4). Versuchen Sie, die x86_64-Bibliothek zusammen mit der Installation der i686-lib zu aktualisieren:

yum install libgcc.x86_64 libgcc.i686
16
etagenklo

Ich habe dies getroffen, nachdem ich yum update Unterbrochen habe (in meinem Fall während eines ansiblen Laufs). Nach dem Lesen von dieser Thread habe ich es schließlich behoben mit:

package-cleanup --cleandupes

Zuvor hatte ich jedoch auch versucht, Befehle auszuführen, wie von @etagenklo vorgeschlagen, und auch versucht:

yum-complete-transaction yum-complete-transaction --cleanup-only yum check # report generally package-cleanup --dupes # report on duplicate packages in particular

4
Hamish Downer

Ich denke, es ist erwähnenswert, weil es meine Problemprüfung war

/etc/yum.repos.d/*

und prüfen Sie, ob es keine verwendete oder inoffizielle Quelle gibt

0