it-swarm.com.de

404-Fehler auf Unterkategorieseiten

Ich habe einige andere Fragen und Antworten zu diesem Thema gesehen, kann sie jedoch derzeit nicht beantworten.

Ich habe einige Kategorien wie folgt eingerichtet:

Blog

- Unterkat

Die Permalinks sind derzeit mit folgendem benutzerdefinierten Typ eingerichtet: /%category%/%postname%/ und die Kategoriebasis ist auf . festgelegt.

Im Moment

  • Wenn ich zu einem Beitrag in einer Unterkategorie gehe, funktioniert es.
  • Der Zugriff auf die übergeordnete Blogkategorie funktioniert.
  • Zugriff auf die untergeordnete Kategorie funktioniert nicht

Ich habe versucht, die Permalinks auf den folgenden /%category%/%subcategory%/%postname%/ zu ändern.

Dies führt zu folgendem Verhalten:

  • Der Zugriff auf die Haupt-Blogkategorie funktioniert.

  • Zugriff auf Unterkategorien funktioniert.

  • Post innerhalb der Unterkategorie funktioniert nicht .

Hinweis: Der Link, zu dem ich weitergeleitet werden soll, lautet wie folgt:

/ blog/sub-cat-name /% subcategory%/langer postname-oder-etwas /

2
StuartM

Die Ursache für dieses Problem zum späteren Nachschlagen war das '.' in der Kategoriebasis, die hinzugefügt wurde, um ein vorheriges Problem zu beheben. Wenn Sie dies entfernen und/category/postname (pro Frage) verwenden, wird nach einer alternativen Lösung für das Kategorie-Basisproblem gesucht.

1
StuartM

Lösung, Permalink> Allgemeine Einstellungen> Benutzerdefinierte Struktur

Benutze diesen Slug: /%category%/

Wählen Sie nur die Unterkategorie für den Beitrag aus. Es ist nicht erforderlich, die übergeordnete Kategorie für einen Beitrag auszuwählen.

0

Sie können Ihre Permalinks ändern und am Ende eine Erweiterung hinzufügen:

/%category%/%postname%.html