it-swarm.com.de

Xubuntu 16.04 bootet nicht. hängt nach fsck

Ich habe gerade xubuntu 16.04LTS auf einem Dell Inspiron Mini als Dual-Boot mit Windows 7 installiert.

Als ich es gestern zum ersten Mal hochfuhr, funktionierte es einwandfrei. Heute sehe ich jedoch Folgendes:

/dev/sda5: recovering journal
/dev/sda5: clean, 174140/6045696 files, 1444115/24179712 blocks

Ich habe mehrere andere Fragen beantwortet, wie Startproblem in 16.04 lts? , Mein Ubuntu führt bei jedem Start fsck aus und Linux hängt beim Booten danach fsck , was darauf hindeutet, dass fsck bei jedem Systemstart ausgeführt wird oder ich fehlende Treiber habe, aber keines davon war genau das gleiche Problem wie ich.

Bei den Problemen, die fsck betreffen, gibt es jedoch einfach eine irritierende Verzögerung. Hier bleibt es auf unbestimmte Zeit bei diesem Bildschirm hängen, soweit ich das beurteilen kann. Ich habe jetzt schon eine ganze Weile gewartet und es hat sich nichts geändert.

Haben Sie mögliche Lösungen? Vielen Dank.

3
Jonathan Lam

Halten Sie Right-Shift gedrückt, um auf den GRUB-Bootloader zuzugreifen. Gehen Sie zu den erweiterten Optionen und starten Sie den Wiederherstellungsmodus. Wenn das Menü für den Wiederherstellungsmodus geöffnet wird, wählen Sie diese Option, um den normalen Startvorgang fortzusetzen. Wenn Sie sich jetzt anmelden müssen Terminal öffnen und Sudo nano /etc/default/grub eingeben

Das habe ich getan.

  1. Ich habe den Teil "splash quiet" in "nomodeset radeon.modeset=0 systemd.recover_state=0" geändert. Wenn ich richtig bin, funktioniert nomodeset auch mit ATI. Ich habe eine alte ATI-Karte, also schien radeon.modeset=0 richtig zu sein, aber ich habe nicht mehr mit diesen gespielt, um wirklich sicher zu sein.

  2. speichern Sie die Datei in Nano, indem Sie ctrl+o drücken und dann ctrl+x beenden.

  3. wieder im Terminal, starte Sudo update-grub

Versuchen Sie nun, mit Sudo reboot einen normalen Neustart durchzuführen, und prüfen Sie, ob Ihr System dadurch normal bootet.

ps. Also liegt das Problem vielleicht bei den Bildschirmtreibern?

3
xSamle

Nachdem ich diese Lösung in einem Archlinux-Forum gefunden hatte, konnte ich endlich mit Lubuntu booten (aber ich glaube, ich werde möglicherweise Xubuntu verwenden).

Bearbeiten Sie die Kernel-Boot-Parameter mit (welcher Texteditor auch immer, ich habe gerade pico verwendet)

Sudo pico /etc/default/grub

und wo es heißt GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

füge systemd.restore_state=0 hinzu, so dass es wie folgt lauten sollte:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash systemd.restore_state=0"

Meine Quelle ist https://bbs.archlinux.org/viewtopic.php?id=201523&p=2

und auch https://bugzilla.redhat.com/show_bug.cgi?id=125352

wo ich im archlinux wiki eine dokumentation zum thema "backlight" gefunden habe. Ich kann es nicht verlinken, da ich nicht genug Repräsentanten habe :( kann höchstens zwei URLs verlinken.

* Edit: hab ich jetzt vielleicht genug rep? Hier habe ich die Informationen gesehen: https://bbs.archlinux.org/viewtopic.php?id=201523&p=2

und

https://bugzilla.redhat.com/show_bug.cgi?id=125352

Ich hoffe, das funktioniert für Sie, ich habe einen Monat gebraucht, um es herauszufinden!

Offenbar eine lange Geschichte, kurz: Beim Booten versucht das System, die Hintergrundbeleuchtung der Tastatur zu steuern, aber dieser Laptop hat nicht einmal eine. Daher muss ein nicht vorhandener Boot-Parameter überprüft werden, ob mit dem Ein- oder Ausschalten des Lichts begonnen werden soll.

1
Aaron Chen

Ich hatte das gleiche problem Festlegen des Kernel-Parameters loglevel=7 Ich habe festgestellt, dass das Einfrieren durch den Vorgang "Journal zu dauerhaftem Speicher leeren" verursacht wird, der niemals endet. Ich habe beschlossen, den gesamten Ordner /var/log/journal zu löschen. Ich glaube, dass dies nicht die richtige Lösung ist, aber es ist die einzige, die für mich funktioniert hat.

0
RobotMan