it-swarm.com.de

Was ist zu tun, wenn das Laden der Kernel-Module fehlgeschlagen ist?

Ich habe versucht, mein System von Ubuntu 14.04 zu aktualisieren. Mein Laptop ist für ein paar Stunden eingefroren. Nicht einmal der Zeiger tat etwas. Also schaltete ich mich aus, indem ich den Ein-/Ausschalter einige Sekunden lang drückte. Diese unvollständige Installation ist der Ursprung meines Problems. Wenn ich das System neu starte, erscheint grub und dann die folgende Meldung:

[FAILED] Failed to start Load Kernel Modules
See 'systemctl status systemd-modules-load.service' for details

Plus einige andere Zeilen, die mit einem Finale enden:

Failed to start Load Kernel Modules

image

Wenn ich eine Befehlszeile mit STRG + ALT + F1 öffne, kann ich eingeben

Sudo systemctl status systemd-modules-load.service

und ich bekomme folgende Ausgabe:

status systemd-modules-load.service

image

Wenn ich den Befehl systemctl wiederhole, erhalte ich manchmal einen anderen Prozess als 179, z. B. 183.

Nur für den Fall, dass es gebraucht wird,

Sudo ls /lib/systemd/system/systemd-modules-load.service

gibt mir

/lib/system/systemd-modules-load

(written in green)

journalctl

gibt viele Daten aus. Die roten Linien sind die folgenden:

Erste rote Linie:

image

Zweite und dritte rote Linie:

image

Vierte rote Linie:

image

Ich schätze ein bisschen Hilfe hier sehr. Ich weiß nicht, was ich als nächstes tun soll, und habe im Web nach nichts gesucht.

43
Francisco

Ich fand genau das, was ich brauchte in einer Diskussion auf ubuntuforums.org. Konkret habe ich nach dem Befehl gesucht:

dpkg --configure -a

Der oben verlinkter Artikel erwähnt vier Befehle, die zur Behebung dieses Problems beitragen können, und weist darauf hin, dass sie möglicherweise "in keiner bestimmten Reihenfolge" wiederholt werden müssen:

apt-get update
dpkg --configure -a
apt-get dist-upgrade
apt-get -f install
21
Francisco

Ich hatte den Eindruck, dass bei einem Update/Kernel-Update etwas schief gelaufen ist:

Booted in Wiederherstellungsmodus.

  • menü "root": manuell gesperrtes Netzwerk

    ifconfig ethx <ip> netmask <mask> up
    echo "nameserver 8.8.8.8" > /etc/resolv.conf
    apt-get update
    
  • menü "dpkg": Reparierte Installation

  • zurück zum menü "root": reparatur kernel initramfs

    update-initramfs -k all -u
    update-grub
    
2
apos

In meinem Fall könnte dies geschehen sein, wenn ein Update der Installation durchgeführt und das System ausgeschaltet wurde, ohne dass es vollständig aktualisiert wurde.

Drücken Sie Ctrl+Alt+F1 (für Befehlszeilenschnittstelle)

Nachdem,

Sudo dpkg --configure -a
Sudo apt-get dist-upgrade 
Sudo apt-get -f install  (this command is optional, because the `dist-upgrade` command should have everything)

Und zuletzt,

Sudo init 6

(System neu starten)

Jetzt sehen Sie Ubuntu 16.04 LTS ohne Fehler.

HINWEIS: Das Update kann einige Zeit dauern. In meinem Fall dauerte es 45-60 min.

1

Ich hatte gerade dieses Problem mit einer Ubuntu 16.04-Installation. Als ich journalctl | grep modules von der Wiederherstellungs-Root-Shell aus betrachtete, bemerkte ich, dass versucht wurde, Module vom 16.10 (neueren) Kernel zu laden. Es sind Daten auf meinem USB-Stick zurückgeblieben, da ich sie nicht formatiert habe, während ich Bilder darauf geschrieben habe (von einem Mac mit Unetbootin).

Also ein Format des USB-Sticks, den bootfähigen Stick neu erstellen, und es war so gut wie Gold.

:)

1
Tim Richardson

Ich habe auch bekommen

Failed to start Load Kernel Modules

jedes Mal beim Start.

Ich habe getan, was Francisco vorgeschlagen hat, aber es hat den Fehler nicht beseitigt.

Was hat funktioniert war Kommentar aus der Zeile Nouveau in meiner/etc/modules-Datei , der nvidia fahrer.

Alle meine Probleme haben angefangen, als ich den Treiber gewechselt habe, so dass es absolut sinnvoll ist. Eine Sache, die mich dazu führte, waren die Linien

... systemd-modules-load[279]: could not find module by name='off'
... Failed to insert 'off': No such file or directory

in meinem/var/log/syslog. Übrigens starte ich Ubuntu 18.04.

0
Mattias

Gleiches Problem zum Upgrade von 12 auf 14 und 14 auf 16. Ohne Lösung: - /

Ich stelle hier die gleiche Frage ohne Lösung:

Die Lösung für mich: PC formatieren.

0
e-info128

Für mich war es ein Problem mit meiner Home-Partition, also löste das Ausführen von fsck /dev/sdb6 und das Beantworten aller Fragen mit Ja das Problem.

Die betroffene Partition ist möglicherweise nicht sdb6 auf Ihrem System. In diesem Fall müssen Sie den Gerätenamen von /dev/sdb6 an den von Ihrer Partition verwendeten Namen anpassen. Wenn Sie den richtigen Pfadnamen nicht kennen, können Sie ihn möglicherweise finden, indem Sie mount ausführen oder den Inhalt von /etc/fstab überprüfen (was Sie mit cat /etc/fstab tun können).

0
DeepKling