it-swarm.com.de

Ubuntu 16.04 bleibt während des Startvorgangs auf dem Startbildschirm hängen

Grundlegende Systemspezifikationen:

  • Samsung SSD 500 GB
  • CPU: Intel i5-7500
  • RAM: 16 GB
  • GPU: NVIDIA GeForce GTX1080
  • Derzeit für Dual Boot mit Windows 10 64-Bit konfiguriert, Windows wird jedoch ohne Probleme gestartet.

Problem:

Ubuntu 16.04 bleibt auf unbestimmte Zeit im Startbildschirm hängen, aber nachdem versucht wurde, das Problem zu beheben, wird es nun erfolgreich im Shell-Modus gestartet. Selbst wenn Sie ESC drücken, während es hängt, werden keine Protokolle angezeigt.

Ich konnte also kein anderes Startprotokoll als SSHing auf meinem Desktop sehen und öffnete /var/log/boot.log

Folgendes habe ich bekommen, während es hing:

[  OK  ] Started Network Manager Wait Online.
[  OK  ] Reached target Network is Online.
[  OK  ] Started Daily apt download activities.
[  OK  ] Started Daily apt upgrade and clean activities.
[  OK  ] Reached target Timers.
[  OK  ] Started crash report submission daemon.
         Starting /etc/rc.local Compatibility...
[  OK  ] Started /etc/rc.local Compatibility.
         Starting Terminate Plymouth Boot Screen...
         Starting Hold until boot process finishes up...

Ich habe auch versucht, dmesg | less nach zahlreichen Google-Versuchen, um die Startprotokolle anzuzeigen, und bin am Ende auf Folgendes gestoßen:

[    2.604476] random: crng init done
[    2.631750] IPv6: ADDRCONF(NETDEV_UP): enp2s0: link is not ready
[    2.651404] r8169 0000:02:00.0 enp2s0: link down
[    2.651432] r8169 0000:02:00.0 enp2s0: link down
[    2.651488] IPv6: ADDRCONF(NETDEV_UP): enp2s0: link is not ready
[    2.691320] NVRM: Your system is not currently configured to drive a VGA console
               on the primary VGA device. The NVIDIA Linux graphics driver
               requires the use of a text-mode VGA console. Use of other console
               drivers including, but not limited to, vesafb, may result in
               corruption and stability problems, and is not supported.
[    2.861207] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input14
[    2.861248] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input15
[    2.861281] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input16
[    2.861312] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input17
[    5.426350] r8169 0000:02:00.0 enp2s0: link up
[    5.426356] IPv6: ADDRCONF(NETDEV_CHANGE): enp2s0: link becomes ready

Es scheint, als gäbe es ein Problem mit der NVIDIA-Karte, wie ich anfangs dachte.

Was ich getan habe, um dieses Problem zu beheben:

  1. Update von GRUB
    • Ging in den Wiederherstellungsmodus und offenes Terminal
    • Der Startmodus wurde von quiet splash in acpi=force geändert, um den Startvorgang in Shell zu erzwingen. Jetzt habe ich das zurückgesetzt.
    • cat /etc/X11/default-display-manager zeigt lightdm als Standard an.
  2. Aktualisieren Sie den Intel-Grafikkartentreiber
  3. Ich habe versucht, Boot-Repair zu verwenden, um Grub-Probleme zu beheben. Die Ergebnisse für Pastebin sind: http://paste.ubuntu.com/25620967/

Was ich möglicherweise getan habe, um dieses Problem zu verursachen:

  1. Sudo service lightdm stop

    • In dem Bemühen, den GPU-Lüfter kopflos zu steuern.
    • Aber ich lief Sudo service lightdm restart
    • Jetzt glaube ich, dass lightdm nicht beim Booten startet.
    • Hier ist der Link , dem ich gefolgt bin, um den GPU-Lüfter fernzusteuern
  2. Sudo service lightdm restart

    • Ich habe versucht, lightdm neu zu starten, und es gibt mir eine positive Ausgabe, die der Anmeldebildschirm ist, aber ich kann hier nichts tun, da es immer noch eingefroren ist.
    • Ich versuche Sachen auf der Tastatur zu tippen, aber es wird nichts angezeigt.

Kann mir bitte jemand helfen, das herauszufinden ??? Ich bin wirklich ahnungslos und werde gleich weinen ...

4
Jay Shin

Also, wie ich oben kommentiert habe, habe ich Ubuntu 16.04 und den nvidia-384-Treiber neu installiert, um meine Theorie über die Ursache dieses Chaos zu testen.

Ich habe diesen Link genau befolgt, um den GPU-Lüfter fernzusteuern.

Es funktioniert wie ein Zauber, aber danach bin ich auf den gleichen Neustartfehler gestoßen.

Dieses Mal konnte ich jedoch einfach Sudo service lightdm restart von meiner SSH-Verbindung aus aufrufen und mich erfolgreich anmelden.

Im Moment habe ich quiet splash in Sudo vim /etc/default/grub in acpi=force geändert, sodass ich Shell direkt ohne Anzeige starten kann.

Das ist wirklich ärgerlich und ich würde jemanden wirklich begrüßen, wenn er/sie eine funktionierende Lösung für dieses Durcheinander vorschlagen könnte.

UPDATE

Ich konnte das Problem am Ende beheben.

Nach einer Neuinstallation von Ubuntu habe ich Folgendes getan, anstatt den Anweisungen im obigen Link zu folgen:

Sudo env DISPLAY=:0 nvidia-settings -a [gpu:0]/GPUFanControlState=1 -a [fan-0]/GPUTargetFanSpeed=100

2
Jay Shin