it-swarm.com.de

Kubuntu funktioniert nach dem Upgrade auf 16.04 nicht mehr

Ich habe einen neuen System76 Lemur Laptop. Es hat gut funktioniert für eine Woche. Ich habe Kubuntu installiert, es hat gut funktioniert. Dann habe ich ein Upgrade auf Kubuntu 16.04 LTS durchgeführt und das System bootet nicht mehr vollständig. Das Kubuntu-Logo blinkt, zeigt dann aber nie die Anmelde-Benutzeroberfläche an. Ich sehe nur Schwarz. Ich kann ein TTY erhalten, indem ich drücke CTRL+ALT+F1 Schlüssel. Ich kann startx -: 1 vom TTY aus ausführen, um eine grafische Oberfläche zu erhalten.

Wie kann ich eine benutzbare grafische Oberfläche erhalten?

5
rrenaud
Sudo dpkg-reconfigure sddm

und die auswahl von sddm hat bei mir funktioniert.

7
Frau Tukka

Lauf

Sudo apt-get install --reinstall kubuntu-desktop plasma-desktop plasma-desktop-data sddm xorg xserver-xorg-core xserver-xorg-video-intel && Sudo dpkg-reconfigure sddm

Im ersten Teil werden Kubuntus KDE-Plasma, der X11-Anzeigeserver, der SDDM-Anzeigemanager und der Intel-Grafiktreiber neu installiert. Mit dem nächsten können Sie ihn als Standard-Anzeigemanager festlegen. Wenn einige dieser Pakete nicht installiert sind, wird versucht, sie zu installieren.

Protokolle befinden sich unter/var/log. Suchen Sie nach dem Protokoll für Xorg und sddm.

4
Enkouyami

Hinweis - Diese Nachricht richtet sich nur an Benutzer von proprietären NVIDIA-Treibern. Ich bin nicht sicher, ob Ihr Laptop einen hat, aber es kann für andere Menschen hilfreich sein, die sich in der gleichen Situation befanden. :

Ich bin gerade auf ein ähnliches Problem gestoßen, nachdem ich mein Kubuntu 16.04-Setup aktualisiert habe (es hat bereits einwandfrei funktioniert). Das Herumspielen von KDE-Paketen hat nicht geholfen. Ich bemerkte jedoch, dass Plasma tatsächlich funktionierte, bekam aber kein echtes visuelles Feedback (Rechtsklick funktionierte, als ob Plasma richtig gestartet worden wäre). Ich könnte in einer Konsole mit Alt + F2 anfangen und es blind starten. Das manuelle Neustarten von KWin (kwin_x11 --replace) hat mir gezeigt, dass das Compositing aufgrund der fehlenden GLX-Erweiterung auf dem X-Server deaktiviert wurde. Es wurde von glxgears bestätigt, die nicht startbereit waren.

Also ließ ich ein TTY fallen, loggte mich ein, Sudo service lightdm stop (Anmerkung: der Standardwert DM unter Kubuntu ist sddm, also wäre es höchstwahrscheinlich Sudo service sddm stop), installierte die nvidia-Treiber neu und startete neu und es hat wieder funktioniert.

Ich frage mich, ob es nur um die X.org-Konfiguration ging (also versuchen Sie zuerst, nvidia-xconfig durcheinander zu bringen), die ersetzt wurde oder ob das Upgrade einige GLX-Bibliotheken kaputt gemacht hat.

Hoffentlich hilft dir das und einigen anderen weiter!

0
Asu