it-swarm.com.de

Apparmor Init Failed, Exit Code 123

Apparmor startet nicht und die Befehlszeile startet mit dem gleichen Ergebnis wie unten

[email protected]:~$ systemctl --failed
  UNIT             LOAD   ACTIVE SUB    DESCRIPTION
● apparmor.service loaded failed failed LSB: AppArmor initialization

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.

1 loaded units listed. Pass --all to see loaded but inactive units, too.
To show all installed unit files use 'systemctl list-unit-files'.

[email protected]:~$ systemctl status apparmor.service
● apparmor.service - LSB: AppArmor initialization
   Loaded: loaded (/etc/init.d/apparmor; bad; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2016-05-03 21:52:29 MDT; 1h 15min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 523 ExecStart=/etc/init.d/apparmor start (code=exited, status=123)

May 03 21:52:22 x-NICEPUTER apparmor[523]: AppArmor parser error for /etc/apparmor.d/usr.bin.webbrowser-app in /etc/apparmor.d/usr.bin.webbrowser-app at line 26: Could not open '/usr/share/apparmor/hardware/graphics.d'
May 03 21:52:28 x-NICEPUTER apparmor[523]: Skipping profile in /etc/apparmor.d/disable: usr.sbin.rsyslogd
May 03 21:52:29 x-NICEPUTER apparmor[523]: Skipping profile in /etc/apparmor.d/disable: usr.bin.firefox
May 03 21:52:29 x-NICEPUTER apparmor[523]: AppArmor parser error for /etc/apparmor.d/usr.bin.webbrowser-app in /etc/apparmor.d/usr.bin.webbrowser-app at line 26: Could not open '/usr/share/apparmor/hardware/graphics.d'
May 03 21:52:29 x-NICEPUTER apparmor[523]: Skipping profile in /etc/apparmor.d/disable: usr.sbin.rsyslogd
May 03 21:52:29 x-NICEPUTER apparmor[523]:    ...fail!
May 03 21:52:29 x-NICEPUTER systemd[1]: apparmor.service: Control process exited, code=exited status=123
May 03 21:52:29 x-NICEPUTER systemd[1]: Failed to start LSB: AppArmor initialization.
May 03 21:52:29 x-NICEPUTER systemd[1]: apparmor.service: Unit entered failed state.
May 03 21:52:29 x-NICEPUTER systemd[1]: apparmor.service: Failed with result 'exit-code'.

Die Verzeichnisse apparmor/hardware/ und die Datei graphics.d sind in /usr/share/ nicht vorhanden. Daher gibt #include /usr/share/apparmor/hardware/graphics.d in Zeile 26 von /etc/apparmor.d/usr.bin.webbrowser-app null zurück und verursacht den Fehler.

Wie kann ich dieses Problem beheben oder zumindest eine Problemumgehung erstellen, mit der apparmor.service ohne Fehler initialisiert werden kann?

uname -a
Linux x-NICEPUTER 4.4.0-21-generic #37-Ubuntu SMP Mon Apr 18 18:33:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
Sudo lshw
[Sudo] password for x: 
x-niceputer               
    description: Computer
    width: 64 bits
    capabilities: smbios-2.4 vsyscall32
  *-core
       description: Motherboard
       physical id: 0
     *-memory
          description: System memory
          physical id: 0
          size: 3793MiB
     *-cpu
          product: Intel(R) Core(TM)2 Duo CPU     P8400  @ 2.26GHz
10
xtrchessreal

Scheint ein gemeldeter Fehler zu sein ( # 15548 )

Es kann gelöst werden, indem apparmor-easyprof-ubuntu installiert oder die Ordner von Hand erstellt werden.

Sudo apt-get install apparmor-easyprof-ubuntu
17
ant

In meinem Fall trat das Problem auf, als ich das snapd-Paket mit apt-get remove snapd deinstallierte. Beim Überprüfen des Syslogs hat das snapd-Deinstallationsprogramm anscheinend einige Verzeichnisse gelöscht, nicht jedoch die darauf verweisenden apparmor-Konfigurationsdateien. Ich habe das Paket mit apt-get purge snapd beschnitten und apparmor ohne Fehler neu gestartet.

1
Fjor

Für mich konnte ich keine Pakete installieren, da sowohl ifconfig als auch network-manager meinen USB-WLAN-Dongle nicht finden/starten konnten.

Also @ xtrchessreal's Kommentar hat bei mir funktioniert :

Erstellen Sie im Wiederherstellungsmodus "Shell" die folgenden Verzeichnisse:

mkdir -p /usr/share/apparmor/hardware/graphics.d
mkdir -p /usr/share/apparmor/hardware/audio.d
mkdir -p /usr/share/apparmor/hardware/video.d

Und dann reboot

1
midopa