it-swarm.com.de

fglrx kein bildschirm auf ubuntu gefunden 14.04

ich habe meinen Computer von 13.10 auf 14.04 aktualisiert, jetzt wird mein Bildschirm nach dem Booten schwarz, aber ich kann auf tty1 zugreifen.

nach ein wenig Experimentieren habe ich versucht, start x zu verwenden. Es gab mir this error (from /var/log/Xorg.0.log).

ich habe versucht :

auch fglrxinfo gab mir dieses Error: unable to open display (null)

und sie alle gaben mir immer noch das gleiche Ergebnis, welche Option habe ich noch? Was soll ich tun und gibt es einen Schritt, den ich vermisse?

dankeschön

2
whale_steward

Was ist das Modell Ihrer Grafikkarte? Es kann mit diesem Befehl gefunden werden:

    lspci | grep VGA

Ich hatte in letzter Zeit das gleiche Problem. Ich hatte ein Ubuntu 13.10 mit einer Radeon HD 3850 mit fglrx-Legacy-Treibern und musste diese entfernen, um auf Ubuntu 14.04 zu aktualisieren. Der generische 14.04-Bildschirmtreiber ist in Ordnung, bietet jedoch nur einen Software-Rendering-Modus. Ich bestätige, dass die Standard-fglrx-Treiber mit alten ATI-Karten wie der HD2xxx-4xxx-Serie nicht funktionieren (schwarzer Bildschirm).

Nach der Installation von 14.04 können Sie versuchen, fglrx-legacy-Treiber mit diesen Befehlen zu installieren (für mich am 13.04+ funktioniert, noch nicht am 14.04 getestet) oder über Synaptic:

    Sudo add-apt-repository ppa:makson96/fglrx
    Sudo apt-get update
    Sudo apt-get upgrade
    Sudo apt-get install fglrx-legacy

weitere Informationen in diesem Beitrag: Radeon HD 2000, 3000, 4000 auf 12.10 Quantal: fglrx (Legacy) 12.6 nicht unterstützt, was tun?

Mit dem folgenden Befehl können Sie testen, ob die Treiber ordnungsgemäß funktionieren

    glxinfo | grep render

Videotreiber sind immer der schmerzhafte Teil. Das interessiert mich auch. Bitte halten Sie uns auf dem Laufenden, wenn Sie Ihr Problem lösen können!

1
oherau

Auch wenn es für den Fragesteller zu spät ist, schreibe ich diese Antwort. Ich weiß nicht, ob dies die richtige Methode ist, wahrscheinlich nicht, und ich bin kein Experte, aber ich weiß, dass dies für mich funktioniert.

Seit der Veröffentlichung von Ubuntu 13.04 hatte ich nach den Upgrades einige Probleme, insbesondere nach dem Booten (ich habe Dual-Boot) erhielt der Monitor kein Signal. Nach mehreren Recherchen im Forum lokalisiere ich das Problem. Ich habe einen alten Monitor und muss daher einige Parameter manuell zur Datei Xorg.conf hinzufügen. In der letzten Veröffentlichung von Ubuntu 14.04 LTS fehlt die Datei Xorg.conf. Hier, was ich Schritt für Schritt mache:

  1. In einem tty-Modus eingeben oder alternativ im Wiederherstellungsmenü die Option root auswählen (und in diesem letzten Fall die Hauptpartition erneut einbinden Sudo mount -o remount,rw /)

  2. Öffne (oder erstelle, wenn es nicht existiert) mit root-Berechtigung die Datei Xorg.conf: Sudo nano /etc/X11/xorg.conf

  3. Bearbeite die Datei mit den richtigen Parametern, hier meine Datei:

    Section "ServerLayout" Identifier "aticonfig Layout" Screen 0 "aticonfig-Screen[0]-0" 0 0 EndSection

    Section "Module" Load "glx" EndSection

    Section "Monitor" Identifier "aticonfig-Monitor[0]-0" Option "VendorName" "ATI Proprietary Driver" Option "ModelName" "Generic Autodetecting Monitor" Option "DPMS" "true" EndSection

    Section "Device" Identifier "aticonfig-Device[0]-0" Driver "fglrx" BusID "PCI:1:0:0" EndSection

    Section "Screen" Identifier "Default Screen" DefaultDepth 24 EndSection

    Section "Screen" Identifier "aticonfig-Screen[0]-0" Device "aticonfig-Device[0]-0" Monitor "aticonfig-Monitor[0]-0" DefaultDepth 24 SubSection "Display" Viewport 0 0 Depth 24 Modes "1280x1024" EndSubSection EndSection

Schließlich müssen Sie neu starten. Beachten Sie, dass ich den Unterabschnittsteil hinzugefügt habe, um das Problem mit dem leeren Bildschirm zu lösen, und dass insbesondere die von mir hinzugefügten Parameter für meinen Bildschirm spezifisch sind.

Wenn Sie ein Experte sind oder einfach Fehler finden, zögern Sie bitte nicht, mich zu korrigieren!

1
amorvincomni

am Ende gab ich es auf und wartete auf eine Antwort, die vielleicht nie kommen würde.

das habe ich also getan:

ACHTUNG: DIES LÖSCHT ALLE IHRE DATEN UND PARTITIONEN, ERSTE SICHERUNG!

  1. testen Sie, ob Ubuntu 14.04 mit Live-CD ordnungsgemäß funktioniert
  2. wählen Sie in der Live-CD "Erase disk" und installieren Sie Ubuntu 14.04
  3. fahren Sie mit der Installation fort

ich weiß nicht, was die Ursache ist, aber mit dieser 'Clean Install'-Lösung kann ich Ubuntu 14.04 verwenden. dennoch hoffe ich, dass jemand eine bessere Antwort oder Lösung zu diesem Problem geben kann.

0
whale_steward