it-swarm.com.de

Wie leeren Sie Ihren Visual Studio-Cache unter Windows Vista?

Ich habe ein Problem, bei dem meine ASP.NET-Steuerelemente nicht im Code hinter den Dateien referenziert werden können.

In der Frage zum Stapelüberlauf wurde eine Lösung gefunden. Auf ASP.NET-Steuerelemente kann in Visual Studio 2008 nicht in CodeBehind verwiesen werden .

Ich kann meinen Visual Studio-Cache jedoch nicht finden, um ihn zu löschen. Ich verwende Visual Studio 2005 unter Windows Vista.

60
Brian G

Die akzeptierte Antwort ergab zwei Standorte:

hier

C:\Dokumente und Einstellungen\Administrator\Lokale Einstellungen\Temp\VWDWebCache

und möglicherweise hier

C:\Dokumente und Einstellungen\Administrator\Lokale Einstellungen\Anwendungsdaten\Microsoft\WebsiteCache

Hast du die probiert?

Zum Hinzufügen bearbeitet

Auf meinem Windows Vista-Computer befindet es sich in

%Temp%\VWDWebCache

und in

%LocalAppData%\Microsoft\WebsiteCache

Aus Ihren zusätzlichen Informationen (in Bezug auf die Team Edition) geht Folgendes hervor: Client-TFS-Cache löschen :

Client-TFS-Cache löschen

Visual Studio und Team Explorer bieten einen Caching-Mechanismus, der möglicherweise nicht mehr synchron ist. Wenn ich mehrere Instanzen eines einzelnen TFS habe, mit dem von einem einzelnen Visual Studio-Client aus eine Verbindung hergestellt werden kann, kann dieser Client verwirrt werden.

Um es zu lösen ..

Löschen Sie unter Windows Vista den Inhalt dieses Ordners

% LocalAppData%\Microsoft\Team Foundation\1.0\Cache

86
GregD

Das habe ich heute erlebt. Der Wert in Config war der aktualisierte, aber die Anwendung gab den älteren Wert zurück, hielt an und startete die Lösung ohne Erfolg.

Also habe ich den .Net Temp Ordner gelöscht.

C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files

Es sollte keine Fehler verursachen, aber um sicher zu gehen, schließen Sie zuerst Ihre Lösung. Löschen Sie die temporären ASP.NET-Dateien und laden Sie Ihre Lösung hoch.

Mein Problem wurde sortiert.

16
Adam

Ich hatte das gleiche Problem, aber als ich die zwischengespeicherten Elemente aus dem temporären Ordner löschte, schlug der Build fehl.

Damit der Build wieder funktioniert, musste ich das Projekt schließen und erneut öffnen.

2
silver