it-swarm.com.de

wine: Hängt von wine1.6 oder wine1.8 ab, wird aber nicht installiert, da Sie defekte Pakete haben

Ich möchte wine unter Ubuntu 16.04 installieren, erhalte jedoch folgende Fehlermeldungen:

$ Sudo apt-get install wine
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine : Depends: wine1.6 or
                 wine1.8 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Auch dies versucht:

$ Sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Ich folgte den Antworten auf Probleme konnten nicht behoben werden, Sie haben defekte Pakete zurückgehalten und führte den folgenden Befehl aus.

dpkg --get-selections | grep hold

Aber es gab keine Ausgabe.

Danach habe ich auch versucht dpkg --get-selections, um alle Pakete zu sehen. Es gab einige mit "deinstallieren", also habe ich folgendes ausgeführt:

$ dpkg --get-selections | grep deinstall
ca-certificates-mono            deinstall
libevent-2.0-5:AMD64            deinstall
libgdata2.1-cil                 deinstall
libglib2.0-cil                  deinstall
libgtk2.0-cil                   deinstall
libmx-1.0-2:AMD64               deinstall
libnewtonsoft-json5.0-cil       deinstall
mono-runtime-common             deinstall
nvidia-304                      deinstall
nvidia-opencl-icd-304           deinstall
tlp                             deinstall
tlp-rdw                         deinstall
transmission-gtk                deinstall
xserver-xorg-legacy             deinstall

Diese Pakete können jedoch nicht deinstalliert werden. Ich habe auch versucht, Antworten zu geben auf Wie löse ich nicht erfüllte Abhängigkeiten nach dem Hinzufügen eines PPA auf? und dieses , aber es hat nichts gelöst.

Ich habe es auch mit Aptitude versucht, aber das Problem ist immer noch dasselbe.

Ich habe es auch mit Synaptic Package Manager versucht. Es ist auch nicht möglich, die Abhängigkeiten aufzulösen.

could not apply changes, fix broken packages first

Ich habe auch die folgenden Befehle ausprobiert:

Sudo aptitude -f install wine
Sudo apt-get dist-upgrade
Sudo apt-get update
dpkg --get-selections | grep hold
dpkg --get-selections
dpkg --get-selections | grep deinstall
Sudo apt-get clean
Sudo apt-get autoclean
Sudo dpkg --configure -a
Sudo aptitude -f install wine
Sudo apt-get -f install wine

Aber keiner von ihnen hat es behoben.

Was kann ich noch probieren?

2
theoneabhinav

Ich verwende Ubuntu 16.04 LTS (64-Bit) und habe den gleichen Fehler festgestellt: "E: Probleme können nicht behoben werden, Sie haben fehlerhafte Pakete angehalten." beim Versuch, mysql-workbench zu installieren.

Ich habe das Problem folgendermaßen gelöst:

  1. Sudo apt autoremove (nicht mehr benötigte Pakete entfernen)
  2. Sudo apt-get update
  3. Sudo apt-get install Paketname (z. B. Wein, MySQL-Workbench usw.)

Ich hoffe, es funktioniert für Sie.

1
ikolim

Stellen Sie sicher, dass Sie das Universums-Repository aktiviert haben. Ubuntu-Software -> Aus dem Internet herunterladbar erst vier prüfen und schließen.

geben Sie den folgenden Befehl im Terminal ein:

$ Sudo apt-get löscht die Eigenschaften der Python3-Software

und dann versuchen zu installieren

$ apt-get -f install (manchmal hat -f nicht funktioniert)

0
Naresh S Nash