it-swarm.com.de

VLC wird in Ubuntu 15.04 nicht installiert

VLC funktionierte einwandfrei, bis ich ein Upgrade auf 15.04 durchführte. Wenn ich versuche, über das Software Center zu installieren, wird folgende Fehlermeldung angezeigt:

The following packages have unmet dependencies:

 vlc: Depends: vlc-nox (= 2.2.0-1) but 2.2.0+ppa2.4 is to be installed
 Depends: libavcodec-extra-56 (>= 6:11.2) but 6:11.2-1 is to be installed
 Depends: libavutil54 (>= 6:11~beta1) but 6:11.2-1 is to be installed
 Depends: libc6 (>= 2.16) but 2.21-0ubuntu4 is to be installed
 Depends: libegl1-x11 but it is a virtual package
 Depends: libfreetype6 (>= 2.2.1) but 2.5.2-2ubuntu3 is to be installed
 Depends: libgcc1 (>= 1:4.1.1) but 1:5.1~rc1-0ubuntu1 is to be installed
 Depends: libgles1 but it is a virtual package
 Depends: libgles2 but it is a virtual package
 Depends: libqtcore4 (>= 4:4.8.0) but 4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6 is to be installed
 Depends: libqtgui4 (>= 4:4.8.0) but 4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6 is to be installed
 Depends: libstdc++6 (>= 4.9) but 4.9.2-10ubuntu13 is to be installed
 Depends: zlib1g (>= 1:1.2.3.3) but 1:1.2.8.dfsg-2ubuntu1 is to be installed

Und über das Terminal:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 vlc : Depends: vlc-nox (= 2.2.0-1) but 2.2.0+ppa2.4 is to be installed
       Recommends: vlc-plugin-notify (= 2.2.0-1) but it is not going to be installed
       Recommends: vlc-plugin-samba (= 2.2.0-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Wenn ich dpkg --get-selections | grep hold mache, scheint es, dass keine Pakete gehalten werden

Wenn ich dpkg --get-selections | grep vlc mache, sieht es so aus:

libvlc5                     install
libvlccore8                 install
vlc-data                    install
vlc-nox                     install

Auch wenn ich versuche, es über das Terminal zu entfernen, heißt es, dass es nicht installiert ist und daher nicht entfernt werden kann. Ich habe auch die tägliche Veröffentlichung videolan ppa mit den gleichen unglücklichen Ergebnissen ausprobiert. Wie kann ich meinen guten alten VLC zurückbekommen? Danke für Ihre Hilfe!

8
paulj

Das Problem scheint in vlc-nox zu liegen, das beim Upgrade von Ubuntu nicht behoben wird. Wenn Sie es zuerst entfernen, sollte alles in Ordnung funktionieren. Sowas in der Art:

Sudo apt-get remove vlc-nox
Sudo apt-get autoremove
Sudo apt-get update

Und dann installiere vlc (3.0 funktionierte für mich):

Sudo add-apt-repository ppa:videolan/master-daily
Sudo apt-get update
Sudo apt-get install vlc

Das sollte funktionieren. Diese PPA enthält täglich wechselnde, möglicherweise instabile oder kaputte Entwicklungsbuilds. Siehe PPA) Beschreibung :

Diese PPA enthält tägliche Builds aus dem VLC-Entwicklungszweig.

10