it-swarm.com.de

Vlc media player kann in ubuntu 16.04 LTS nicht installiert werden

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
vlc : Depends: vlc-nox (= 2.2.2+git20160830+r58831+56~ubuntu16.04.1) but it is not going to be installed
   Depends: libavcodec-ffmpeg56 (>= 7:2.4) but it is not going to be installed or
            libavcodec-ffmpeg-extra56 (>= 7:2.4) but it is not going to be installed
   Depends: libavutil-ffmpeg54 (>= 7:2.4) but it is not going to be installed
   Depends: libgles1-mesa (>= 7.8.1) but it is not going to be installed or
            libgles1
   Depends: libgles2-mesa (>= 7.8.1) but it is not going to be installed or
            libgles2
   Depends: libqt5x11extras5 (>= 5.1.0) but it is not going to be installed
   Depends: libsdl-image1.2 (>= 1.2.10) but it is not going to be installed
   Depends: libsdl1.2debian (>= 1.2.11) but it is not going to be installed
   Depends: libva-drm1 (>= 1.1.0) but it is not going to be installed
   Depends: libva-x11-1 (>= 1.0.3) but it is not going to be installed
   Depends: libva1 (>= 1.2.0) but it is not going to be installed
   Depends: libvlccore8 (>= 2.2.0) but it is not going to be installed
   Depends: libxcb-composite0 but it is not going to be installed
   Depends: libxcb-xv0 (>= 1.2) but it is not going to be installed
   Recommends: vlc-plugin-notify (= 2.2.2+git20160830+r58831+56~ubuntu16.04.1) but it is not going to be installed
   Recommends: vlc-plugin-samba (= 2.2.2+git20160830+r58831+56~ubuntu16.04.1) but it is not going to be installed
   Conflicts: vlc:i386 but 2.1.4-1 is to be installed
vlc:i386 : Depends: vlc-nox:i386 (= 2.1.4-1) but it is not going to be installed
        Depends: libaa1:i386 (>= 1.4p5) but it is not going to be installed
        Depends: libc6:i386 (>= 2.15) but it is not going to be installed
        Depends: libcaca0:i386 (>= 0.99.beta17-1) but it is not going to be installed
        Depends: libfreetype6:i386 (>= 2.2.1) but it is not going to be installed
        Depends: libfribidi0:i386 (>= 0.19.2) but it is not going to be installed
        Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
        Depends: libgl1-mesa-glx:i386 but it is not going to be installed or
                 libgl1:i386
        Depends: libqtcore4:i386 (>= 4:4.8.0) but it is not going to be installed
        Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not going to be installed
        Depends: libsdl-image1.2:i386 (>= 1.2.10) but it is not going to be installed
        Depends: libsdl1.2debian:i386 (>= 1.2.11) but it is not going to be installed
        Depends: libstdc++6:i386 (>= 4.6) but it is not going to be installed
        Depends: libtar0:i386 but it is not going to be installed
        Depends: libva-x11-1:i386 (> 1.3.0~) but it is not going to be installed
        Depends: libva1:i386 (> 1.3.0~) but it is not going to be installed
        Depends: libvlccore7:i386 (>= 2.1.0) but it is not installable
        Depends: libx11-6:i386 but it is not going to be installed
        Depends: libxcb-composite0:i386 but it is not going to be installed
        Depends: libxcb-keysyms1:i386 (>= 0.3.9) but it is not going to be installed
        Depends: libxcb-randr0:i386 (>= 1.1) but it is not going to be installed
        Depends: libxcb-shm0:i386 but it is not going to be installed
        Depends: libxcb-xv0:i386 (>= 1.2) but it is not going to be installed
        Depends: libxcb1:i386 (>= 1.6) but it is not going to be installed
        Depends: libxext6:i386 but it is not going to be installed
        Depends: libxinerama1:i386 but it is not going to be installed
        Depends: libxpm4:i386 but it is not going to be installed
        Depends: zlib1g:i386 (>= 1:1.2.3.3) but it is not going to be installed
        Recommends: vlc-plugin-notify:i386 (= 2.1.4-1) but it is not going to be installed
        Recommends: vlc-plugin-Pulse:i386 (= 2.1.4-1) but it is not installable
        Conflicts: vlc but 2.2.2+git20160830+r58831+56~ubuntu16.04.1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Ich habe alles versucht -f-f install

Aber nichts scheint zu funktionieren. das ist nicht alles, wann immer ich es versuche Sudo apt upgrade

Ich erhalte den folgenden Fehler

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 vlc:i386 : Depends: vlc-nox:i386 (= 2.1.4-1) but it is not installed
            Depends: libaa1:i386 (>= 1.4p5) but it is not installed
            Depends: libc6:i386 (>= 2.15) but it is not installed
            Depends: libcaca0:i386 (>= 0.99.beta17-1) but it is not installed
            Depends: libfreetype6:i386 (>= 2.2.1) but it is not installed
            Depends: libfribidi0:i386 (>= 0.19.2) but it is not installed
            Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
            Depends: libgl1-mesa-glx:i386 but it is not installed or
                     libgl1:i386
            Depends: libqtcore4:i386 (>= 4:4.8.0) but it is not installed
            Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not installed
            Depends: libsdl-image1.2:i386 (>= 1.2.10) but it is not installed
            Depends: libsdl1.2debian:i386 (>= 1.2.11) but it is not installed
            Depends: libstdc++6:i386 (>= 4.6) but it is not installed
            Depends: libtar0:i386 but it is not installed
            Depends: libva-x11-1:i386 (> 1.3.0~) but it is not installed
            Depends: libva1:i386 (> 1.3.0~) but it is not installed
            Depends: libvlccore7:i386 (>= 2.1.0) but it is not installable
            Depends: libx11-6:i386 but it is not installed
            Depends: libxcb-composite0:i386 but it is not installed
            Depends: libxcb-keysyms1:i386 (>= 0.3.9) but it is not installed
            Depends: libxcb-randr0:i386 (>= 1.1) but it is not installed
            Depends: libxcb-shm0:i386 but it is not installed
            Depends: libxcb-xv0:i386 (>= 1.2) but it is not installed
            Depends: libxcb1:i386 (>= 1.6) but it is not installed
            Depends: libxext6:i386 but it is not installed
            Depends: libxinerama1:i386 but it is not installed
            Depends: libxpm4:i386 but it is not installed
            Depends: zlib1g:i386 (>= 1:1.2.3.3) but it is not installed
            Recommends: vlc-plugin-notify:i386 (= 2.1.4-1) but it is not installed
            Recommends: vlc-plugin-Pulse:i386 (= 2.1.4-1) but it is not installable
E: Unmet dependencies. Try using -f.

Ich habe sogar den -f ausprobiert, aber es passiert immer noch nichts.

Bitte helfen Sie

12
Akash Sarpal

Die einzige Lösung für dieses Problem ist das Hinzufügen von Padoka Mesa Stable Repository.

https://launchpad.net/~paulo-miguel-dias/+archive/ubuntu/pkppa

Dann renne

Sudo apt-get install vlc

Es wird mit Sicherheit funktionieren, da im obigen Repository sowohl libgles1-mesa als auch libgles2-mesa für vlc erforderlich sind.

22
Aadarsh

Versuchen:

Sudo apt-get --purge remove vlc*
Sudo apt-get autoremove
Sudo apt-get update
Sudo apt-get upgrade
Sudo apt-get install vlc
5
Black_FireFox

Sie können versuchen, dasselbe mit dem folgenden Befehl zu befolgen

Sudo apt-get install aptitude
Sudo aptitude install vlc
3
vembutech

Ich hatte genau das gleiche Problem mit Bibliotheken (kann vlc aufgrund von Problemen mit libgles1-mesa- und libgles2-mesa-Bibliotheksabhängigkeiten nicht installieren). Ich könnte das Problem mit aptitude lösen.

Aufgrund von Problemen mit der Bibliotheksabhängigkeit konnte ich vlc jedoch nicht sofort installieren.

Zuerst musste ich libgles1-mesa mit $ Sudo aptitude aktualisieren und libgles1-mesa installieren

auf die Frage zur vorgeschlagenen Lösung (nicht installierte Bibliothek beibehalten) Antwort: NEIN

akzeptieren Sie dann den alternativen Vorschlag: Zurücksetzen von libgl1-mesa-glx und libglapi-mesa auf frühere Versionen

dann fuhr ich mit libgles2-mesa fort mit: $ Sudo aptitude install libgles2-mesa

dieses Mal hatte die vorgeschlagene Lösung kein Problem und installierte die Bibliothek

Zu diesem Zeitpunkt konnte ich vlc mit $ Sudo apt-get install vlc installieren

und VLC war in Betrieb Hove, es funktioniert auch für Sie!

1
Thierry B

Sie haben 2 Möglichkeiten:

  1. Installieren Sie es direkt vom "Software Center". Gehen Sie zur Ubuntu-Software und geben Sie im Suchfeld "VLC" ein. Dort finden Sie den Player und können ihn installieren, indem Sie auf klicken Install.

  2. Probieren Sie die folgenden Befehle Schritt für Schritt im Terminal aus:

    Sudo apt-get update
    Sudo apt-get install vlc
    
    Sudo apt-get install vlc browser-plugin-vlc (embedded in Mozilla Firefox)
    
0
Avani badheka

Fügen Sie die PPA für tägliche Pre-Release Builds von VLC hinzu und installieren Sie sie:

Sudo add-apt-repository ppa:videolan/master-daily
Sudo apt update
Sudo apt install vlc

Öffnen Sie nun VLC über Unity Dash (oder einen entsprechenden App-Launcher).

0
Avani badheka