it-swarm.com.de

VLC-Installationsfehler mit "defekten Paketen"

Aus irgendeinem Grund verschwand VLC. Ich kann mich wirklich nicht erinnern, ob es etwas war, was ich getan habe oder ein seltsames Update. Wie dem auch sei, das Programm öffnete sich nicht, aber ich konnte sehen, dass es immer noch installiert war. Ich habe es gelöscht und seitdem versucht, es neu zu installieren.

Sudo apt install vlc gibt die folgende Ausgabe aus:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 vlc : Depends: libgles1-mesa (>= 7.8.1) but it is not going to be installed or
                libgles1
E: Unable to correct problems, you have held broken packages.

Das fühlte sich nicht richtig an. Also google ich kaputte Paketfehler nach Lösungen und meistens lief Sudo apt clean oder in Synaptic. Ich habe beides vergebens getan.

Als nächstes gehe ich davon aus, dass das Paket installiert werden muss. Ich öffne Synaptic und suche nach diesem libgles... finde die Pakete, drücke install ... error. Dieses Paket ist abhängig von libglapi-mesa, Ich suche danach und stelle fest, dass es bereits installiert ist. An diesem Punkt bin ich dem Kaninchenbau gefolgt und weiß nicht, wohin ich jetzt gehen soll.

http://imgur.com/a/rNfMY

1
shmink

Ich hatte heute Morgen nach einem Synaptic-Update ein ähnliches Problem. VLC wurde als Teil dieses Updates entfernt. Als ich versuchte, neu zu installieren, stieß ich auf das ungelöste Abhängigkeitsproblem mit libgles1-mesa. Ich konnte VLC neu installieren, nachdem ich die Ubuntu-X-Swat-PPA gelöscht hatte, die ich meinem System hinzugefügt hatte. Ich leite derzeit Lubuntu 16.04.02 LTS. Möglicherweise möchten Sie überprüfen, ob sich diese PPA in Ihren Repositorys befindet.

1
user670371

Ich kenne die Ursache des Problems nicht, habe aber ein Upgrade von Ubuntu 16.04.2 auf Ubuntu 16.10 auf Ubuntu 17.04 durchgeführt. - Ich habe diese PPA verwendet: videolan-ubuntu-stable-daily-zesty

Ich habe diese Lösung gefunden:

  • 1) Sudo apt Update
  • 2) Sudo apt dist-upgrade
  • 3) Sudo apt install -f
  • 4) Neustart
  • 5) Mit Synaptic Package Manager habe ich alle vlc- * Pakete von Version 1: 2.2.1-dmo3 entfernt **
  • 6) Nach der Installation von Synaptic habe ich die VLC-Version 2.2.4-14ubuntu2 für Ubuntu 17.04 installiert
0
angelohp