it-swarm.com.de

Ubuntu 16.04, Installation von Updates gab einen Fehlercode zurück (1)

Unter Ubuntu 16.04 wurde routinemäßig ein Update durchgeführt und ein Upgrade einiger Multimedia-Codec-Bibliotheken durchgeführt

List of libraries to be updated

Ich habe das Upgrade wie im obigen Bild gezeigt bestätigt. Dann gab der Aktualisierungsprozess den Fehlercode (1) zurück und konnte die Aktualisierung nicht abschließen.

Broken Pipe, /usr/bin/dpkg returns an error code

Jetzt erhalte ich diese unerfüllte Abhängigkeitssache, wenn ich versuche, etwas im Zusammenhang mit dem Upgrade zu tun.

The following packages have unmet dependencies:
 libavcodec-extra57 : Depends: libx265-102 (>= 2.2) but it is not installed
 x265 : Depends: libx265-102 (>= 2.2) but it is not installed
        Depends: libx265-102 (< 2.3) but it is not installed
E: Unmet dependencies. Try using -f.

Ich bin besorgt. Kann ich den Status wiederherstellen, bevor ich versuche, ein Upgrade durchzuführen?

2
Vemulo

Ich habe mein Problem folgendermaßen gelöst: dpkg overwrite

Konkret habe ich eingegeben:

Sudo dpkg -i --force-overwrite /var/cache/apt/archives/libx265-102_2.2-1~16.04.york0_AMD64.deb
4
Vemulo

Versuchen wir zunächst, den "teilweisen" Fehler zu beseitigen. Sei sehr vorsichtig mit diesen Befehlen:

Sudo rm -vf /var/lib/apt/lists/partial/*  # Remove files in 'partial'
Sudo rm -vf /var/lib/apt/lists/*  # Remove package lists in 'lists'
Sudo apt-get update

Wenn weiterhin ein Statusfehler angezeigt wird, versuchen Sie, eine Sicherungskopie der Datei wiederherzustellen:

Sudo mv /var/lib/dpkg/status /var/lib/dpkg/status.0715
Sudo cp /var/backups/dpkg.status.0 /var/lib/dpkg/status
Sudo apt-get update
1
Smagul Zhanibek